You are not logged in.

#1 2012-10-16 20:20:52

centos
Member
From: Ostrava, Czech Republic
Registered: 2009-01-09
Posts: 65

[SOLVED] Can not install XBMC (glu package)

Hello, I'm having trouble installing XBMC. One of the dependencies is glu and trying to install it fails:

glu: /usr/include/GL/glu.h již existuje v souborovém systému
glu: /usr/include/GL/glu_mangle.h již existuje v souborovém systému
glu: /usr/lib/libGLU.so již existuje v souborovém systému
glu: /usr/lib/libGLU.so.1 již existuje v souborovém systému
glu: /usr/lib/pkgconfig/glu.pc již existuje v souborovém systému

This means that these files already exist in the filesystem. Mesa package ownes them:

honza@inkognito ~
  % pacman -Qo /usr/lib/libGLU.so                                                    !372
/usr/lib/libGLU.so vlastní mesa 8.0.4-3

I don't think removing mesa is a good idea. Any other ideas? Thanks.

Last edited by centos (2012-10-16 21:04:59)

Offline

#2 2012-10-16 20:24:03

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] Can not install XBMC (glu package)

Update your system. The current mesa is version 9.0-1.

Offline

#3 2012-10-16 20:27:14

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,706
Website

Re: [SOLVED] Can not install XBMC (glu package)

Mesa certainly does not own those files ... at least not the current version I have on my system.  But my version is ahead of yours, when was your last 'pacman -Syu'?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2012-10-16 20:30:26

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,454
Website

Re: [SOLVED] Can not install XBMC (glu package)

@OP - Always sync and update before installing a new package, i.e.

# pacman -Syu
# pacman -S newpackage

CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#5 2012-10-16 20:32:39

centos
Member
From: Ostrava, Czech Republic
Registered: 2009-01-09
Posts: 65

Re: [SOLVED] Can not install XBMC (glu package)

Ha, that's so much easier than I thought. Thanks karol smile

Offline

#6 2012-10-16 21:03:41

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] Can not install XBMC (glu package)

Please remember to mark the thread as solved.

Offline

#7 2012-10-16 21:04:31

centos
Member
From: Ostrava, Czech Republic
Registered: 2009-01-09
Posts: 65

Re: [SOLVED] Can not install XBMC (glu package)

Trilby wrote:

when was your last 'pacman -Syu'?

Not sure, about a week ago.
And this changed:

honza@inkognito ~
  % pacman -Qo /usr/lib/libGLU.so                                                    !380
/usr/lib/libGLU.so vlastní glu 9.0.0-1

graysky: will do

Last edited by centos (2012-10-16 21:05:57)

Offline

#8 2012-10-16 21:06:21

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] Can not install XBMC (glu package)

centos wrote:
Trilby wrote:

when was your last 'pacman -Syu'?

Not sure, about a week ago.

You can check your pacman.log to be sure :-) e.g. use whatdidido https://bbs.archlinux.org/viewtopic.php … 87#p626487 or just

grep "starting full system upgrade" /var/log/pacman.log | tail -n1

Last edited by karol (2012-10-16 21:07:44)

Offline

#9 2012-10-16 21:21:00

centos
Member
From: Ostrava, Czech Republic
Registered: 2009-01-09
Posts: 65

Re: [SOLVED] Can not install XBMC (glu package)

Ten days ago wink

Offline

Board footer

Powered by FluxBB