You are not logged in.

#1 2012-10-18 16:50:40

Hurricane
Member
Registered: 2012-10-18
Posts: 77

[SOLVED]ld cannot find -l-L/usr/lib -lalleg error

I just installed allegro4 (I know it's outdated but I don't really know much allegro 5 and I need to make a game as a project for school), and everything seems to be working fine. I'm using Code::Blocks. In the Settings->Compiler and Debugger window under the Linker Settings tab I have set

`allegro-config --libs`

When I compile, I get the following error

ld cannot find -l-L/usr/lib -lalleg

I've tried searching for errors similar to this on google but I haven't had much luck.

Last edited by Hurricane (2012-10-18 21:41:38)


Computers are extra dumb, which is why it takes extra smart people to make them work.

Offline

#2 2012-10-18 19:39:50

axs
Member
Registered: 2009-01-23
Posts: 66
Website

Re: [SOLVED]ld cannot find -l-L/usr/lib -lalleg error

It should be -L/usr/lib -lalleg; judging by the message, you have -l"-L/usr/lib -lalleg"
My guess is that you put `allegro-config --libs` where your IDE expects library name while it should go to where IDE expects linker options.

Offline

#3 2012-10-18 21:41:18

Hurricane
Member
Registered: 2012-10-18
Posts: 77

Re: [SOLVED]ld cannot find -l-L/usr/lib -lalleg error

axs wrote:

It should be -L/usr/lib -lalleg; judging by the message, you have -l"-L/usr/lib -lalleg"
My guess is that you put `allegro-config --libs` where your IDE expects library name while it should go to where IDE expects linker options.

That worked perfectly. Thank you very much.


Computers are extra dumb, which is why it takes extra smart people to make them work.

Offline

Board footer

Powered by FluxBB