You are not logged in.

#1 2012-10-20 02:47:25

Registered: 2012-10-20
Posts: 2

Macbook Pro 8,2 (2011) - Unable to locate a BIOS ROM

Hi, everyone! I've had pretty good luck getting Arch running on my MBP 8,2 with hybrid graphics, using the integrated intel device. However, I'd very much like to be able to use VGA switcheroo and have an external display available.

I've extracted the vbios and int10 files as described here:,2

And placed those files in /boot, as suggested (as well as /lib/firmware/radeon). I can manually load the firmware in GRUB via loadbios without throwing any errors, and everything seems to work as planned. However, when I load the radeon module up, this is what appears:

[10106.929747] [drm] radeon kernel modesetting enabled.
[10106.929782] checking generic (90010000 510000) vs hw (90000000 10000000)
[10106.929783] fb: conflicting fb hw usage radeondrmfb vs EFI VGA - removing generic driver
[10106.929818] Console: switching to colour dummy device 80x25
[10106.930237] [drm] initializing kernel modesetting (CAICOS 0x1002:0x6760 0x106B:0x00E1).
[10106.930310] [drm] register mmio base: 0xB0800000
[10106.930311] [drm] register mmio size: 131072
[10106.930313] vga_switcheroo: enabled
[10106.930351] radeon 0000:01:00.0: Invalid ROM contents
[10106.930395] radeon 0000:01:00.0: Invalid ROM contents
[10106.930400] [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
[10106.930402] radeon 0000:01:00.0: Fatal error during GPU init
[10106.930403] [drm] radeon: finishing device.
[10106.930405] [TTM] Memory type 2 has not been initialized
[10106.931439] vga_switcheroo: disabled
[10106.931847] radeon: probe of 0000:01:00.0 failed with error -22

I've searched just about everywhere I can think of, and have even tried the vbios and int10 files from others' MBP8,2 in case mine was bad (booted into a liveCD using BIOS emulation and did the extraction). Everything else is working great, and I'd hate to have to go back to OSX just because of this.

In case it's relevant, I'm using linux-mainline (3.7-rc1) built from AUR, with the default options. My GRUB boot line looks like this:

menuentry 'Arch GNU/Linux, with Linux mainline kernel' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-mainline kernel-true-d00b9933-ff02-4c0a-89f1-00fed33e0841' {
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod ext2
        outb 0x728 1
        outb 0x710 2
        outb 0x740 2
#       outb 0x750 0
        set root='hd0,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  8636ee87-53e7-4cdd-90d6-8473a41871bd
          search --no-floppy --fs-uuid --set=root 8636ee87-53e7-4cdd-90d6-8473a41871bd
        loadbios /vbios.bin /int10.bin
        echo    'Loading Linux mainline kernel ...'
        linux   /vmlinuz-linux-mainline root=UUID=d00b9933-ff02-4c0a-89f1-00fed33e0841 ro i915.modeset=1 i915.lvds_channel_mode=2 i915.lvds_use_ssc=0 acpi_backlight=vendor add_efi_memmap

I'd appreciate any help! I'm totally stuck here.


#2 2012-10-21 00:33:30

Registered: 2012-10-20
Posts: 2

Re: Macbook Pro 8,2 (2011) - Unable to locate a BIOS ROM

Update: I have now tried compiling vbios.bin and int10.bin directly into the kernel. No success.


Board footer

Powered by FluxBB