You are not logged in.

#1 2012-10-20 17:55:44

Los Frijoles
Registered: 2012-06-23
Posts: 38

[SOLVED] Rosewill RNX-N300X doesn't like WPA2?

My apartment complex just recently got rid of their wired internet (NO!!!!!) and switched entirely to wireless. As part of this, they added some wireless security to the network that wasn't there before (it was just open before). For some reason, since this switch to secure (WPA2) wireless I have been having an incredibly hard time with my wireless card ( … s-Adapters). Here is what I have been seeing:

1) It gets low reception (that might just be because I have the computer on the floor) and disconnects every so often (a few minutes to a few is very inconsistent) (the previous network would stay connected for days on end)
2) It takes a very long time to connect at times and fails to connect very often (and keeps asking me for the password)
3) On the Windows side of my hard drive, it causes the entire system to stutter every 5 seconds or so when connected to this new secured wireless (it never did that before). This is manifested in the GUI by the mouse stuttering as it moves across the screen and manifested in audio by a loud buzzing during the stutter. This makes me think that there are hardware problems.
4) As a side note that might be relevant: During startup, it takes a ...very...long...time... to start 'network'. The time is on the order of nearly two minutes sometimes which really kills my startup time (my laptop running Arch on a processor running at half the frequency with a quarter of the cores starts in less than 60 desktop now takes 2 minutes or more). This is what makes me think there are driver problems.

Currently I am running NetworkManager (because it has a nice applet for gnome3), but when I tried to switch to wicd (stopped network and networkmanager then started wicd and ran wicd-client) it couldn't see any networks when I tried to scan. I would like to keep NetworkManager because of the applet, but I am open to switching from Gnome if I must to be able to have a tray icon for wicd.

lspci -v gives the following for the wireless card:

04:00.0 Network controller: Ralink corp. RT2800 802.11n PCI
	Subsystem: Ralink corp. Device 2860
	Flags: bus master, slow devsel, latency 32, IRQ 16
	Memory at f7c00000 (32-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Kernel driver in use: rt2800pci

Also, I am using linux-firmware 20120227-2 instead of the current linux-firmware 20120625-1. This is because after that update, my wireless card stopped working (

Does anyone have any thoughts as to what I can do to improve the card's performance (getting a new card is not ruled out...I just expected this one to last longer than 10 months)?

Last edited by Los Frijoles (2012-11-28 06:36:19)


#2 2012-11-28 06:36:03

Los Frijoles
Registered: 2012-06-23
Posts: 38

Re: [SOLVED] Rosewill RNX-N300X doesn't like WPA2?

It was the driver. Turns out the default windows driver isn't quite as good as the linux driver, but after an update it worked.

In linux, switching off network, using systemd, and using a different manager improved the startup time significantly.


Board footer

Powered by FluxBB