You are not logged in.

#1 2012-10-21 01:41:10

Registered: 2012-07-29
Posts: 66

[SOLVED] Wireless keeps disconnecting

I haven't updated my system in ~2 days, and I finally got around to it a while ago. After the update, my wireless continuously connects and then disconnects, with dmesg outputing (the *'s are something that looks like an ipv4 address):

[17633.903009] wlan0: associated
[17643.973310] wlan0: deauthenticating from * by local choice (reason=3)
[17643.993169] cfg80211: Calling CRDA to update world regulatory domain
[17645.026795] wlan0: authenticate with *
[17645.042674] wlan0: send auth to * (try 1/3)
[17645.044141] wlan0: authenticate with *
[17645.052211] wlan0: send auth to * (try 1/3)
[17645.052342] wlan0: authenticated
[17645.062630] wlan0: associating with AP with corrupt beacon
[17645.065792] wlan0: associate with * (try 1/3)
[17645.070339] wlan0: RX AssocResp from *(capab=0x411 status=0 aid=2)
[17645.070521] wlan0: associated

lspci | grep Network outputs

07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

It doesn't matter if I use wicd or manual wpa_supplicant. Could someone please help me with this?

EDIT: Oops, rebooting seems to have fixed it... sorry... I should probably do that more often.

Last edited by alexanderthegre (2012-10-21 02:27:50)


Board footer

Powered by FluxBB