You are not logged in.

#1 2005-09-10 19:34:21

Registered: 2004-12-10
Posts: 271

No dev naming for SCSI DVD drive? [solved]

I've been trying for sometime to find the udev conversion for the SCSI CD/DVD drive I have.

'dvd' doesn't exist
hdc is taken
sda1 is taken by the root hard drive
sda2 is taken by the swap file
If I put /dev/sd in fstab, then try mount /mnt/cd2 (which is a valid mount point), it says special device 'sd' doesn't exist.

I guess I could always stick to the old name, but then it wouldn't be udev, would it?  It works by the old name. 

I haven't tried it yet, but the only thing I found closest was:


except the actual lun is 2 on the DVD drive's controller, but I think the kernel is using target2 as the lun, and lun0 is what the drive is according to it not being chained.  target0 seems to be related to my SCSI hard drive.

Thanks in advance.


#2 2005-09-10 19:41:05

Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108

Re: No dev naming for SCSI DVD drive? [solved]

shouldn't it be /dev/sdb?


#3 2005-09-10 19:43:21

Registered: 2004-12-10
Posts: 271

Re: No dev naming for SCSI DVD drive? [solved]

mount: special device /dev/sdb does not exist

sorry about that, I thought about that too, but I didn't mention it because I was browsing the /dev/ directory and noticed it wasn't listed there.


I guess it would help to list my configuration, because there's probably an even more obvious reason for it, but I"m not sure.

Adaptec 29160N PCI card, has 68-pin and 50-pin connector.  The hdd and DVD drive are both connected to this controller card but to their according connector directly to the board.  They both come up in the bios screen with the HDD as LUN0 and DVD drive as LUN2.  The dvd drive works so far only if specified as /dev/cdroms/cdrom1.

I'm sure this is nit-picking, but I'm just concerned it might translate into a problem down the road.  If it's not an issue, just tell me.  LOL.


Latest issue:  I noticed today that my Arch kernel says 2.6.12-ARCH (shouldn't it be X.X.X-SCSI?), and also my /dev path has dumped a ton of useless references, and also added an scd0 reference (which I'm wondering if this might be my SCSI drive?)....*edit again, wait, finally there's dvd and dvd1, I bet dvd is the IDE burner, and dvd1 is the SCSI dvd drive.  Hmmmm...  I'll try changing these in the media file and fstab and report back.

*edit [still working on it]

Yes, uh, it appears to be scd0.  Where did this come from?   I know it wasn't there before, and neither was dvd or dvd1.  Which, as suspected, dvd1 and scd0 are both linked to the SCSI DVD drive.   :?:

I tend to think the difference was between using hotplug and lshwd since it was recently I switched to lshwd.  I also optimized pacman (pacman-optimize), but I wouldn't think that has anything to do with it.


Board footer

Powered by FluxBB