You are not logged in.

#1 2012-10-21 19:47:15

redgrave
Member
Registered: 2010-09-27
Posts: 8

Locale problem via SSH and X2GO

Hi everyone,

I apologize in advance for my english

I searched the forum already and tryied several solutions, but I can't set my locales right.

I even tryied to copy one of my friends locale.conf and locale.gen files to try...

Here's the output of "locale"

LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

Here's the "locale -a"

C
POSIX
fr_CH
fr_CH.iso88591
fr_CH.utf8
fr_FR
fr_FR.iso88591
fr_FR.utf8
franais
french

And here's my /etc/locale.conf file

LANG=fr_CH.UTF-8

The local problem is present via SSH and X2go. I never tested it with a real screen and a real keyboard on the computer.

I use xfce4 and start it with the command: "xfce4-session" via X2go on a Windows 7 machine I use to work.

I also tryied to launch KDE with X2GO, but have the same problem.

When I connect with putty via SSH, I don't apply any special parameters.


Anyone have an idea ?

Thanks

Last edited by redgrave (2012-10-21 20:12:00)

Offline

#2 2012-10-21 19:50:01

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Locale problem via SSH and X2GO

Read https://plus.google.com/114015603831160 … zKCcnTWDpa and try setting ~/.config/locale.conf.
What's the output of 'cat /etc/profile.d/locale.sh'?

Offline

#3 2012-10-21 20:06:36

redgrave
Member
Registered: 2010-09-27
Posts: 8

Re: Locale problem via SSH and X2GO

Hi Karol,

Thanks for your reply.

I got SSH working (my bad... I forgot that windows doesn't use UTF-8 by default...)

I still have problems with X2Go.


Here's the output:

#!/bin/sh

unset LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES \
      LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT LC_IDENTIFICATION

if [ -n "$XDG_CONFIG_HOME" ] && [ -r "$XDG_CONFIG_HOME/locale.conf" ]; then
  . "$XDG_CONFIG_HOME/locale.conf"
elif [ -n $HOME ] && [ -r $HOME/.config/locale.conf ]; then
  . "$HOME/.config/locale.conf"
elif [ -r /etc/locale.conf ]; then
  . /etc/locale.conf
elif [ -r /etc/rc.conf ]; then
  LANG=$(. /etc/rc.conf 2>/dev/null; echo "$LOCALE")
fi

export LANG="${LANG:-C}"
[ -n "$LC_CTYPE" ]          && export LC_CTYPE
[ -n "$LC_NUMERIC" ]        && export LC_NUMERIC
[ -n "$LC_TIME" ]           && export LC_TIME
[ -n "$LC_COLLATE" ]        && export LC_COLLATE
[ -n "$LC_MONETARY" ]       && export LC_MONETARY
[ -n "$LC_MESSAGES" ]       && export LC_MESSAGES
[ -n "$LC_PAPER" ]          && export LC_PAPER
[ -n "$LC_NAME" ]           && export LC_NAME
[ -n "$LC_ADDRESS" ]        && export LC_ADDRESS
[ -n "$LC_TELEPHONE" ]      && export LC_TELEPHONE
[ -n "$LC_MEASUREMENT" ]    && export LC_MEASUREMENT
[ -n "$LC_IDENTIFICATION" ] && export LC_IDENTIFICATION

Last edited by redgrave (2012-10-21 20:12:21)

Offline

#4 2012-10-21 20:11:03

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Locale problem via SSH and X2GO

I know nothing about X2Go :-(

When pasting code, please use [ code ] tags, not [ quote ] tags https://bbs.archlinux.org/help.php#bbcode

like this

It makes the code more readable and - in case of longer listings - more convenient to  scroll through.

Offline

#5 2012-10-21 20:22:40

redgrave
Member
Registered: 2010-09-27
Posts: 8

Re: Locale problem via SSH and X2GO

Noted.

Setting a user locale didn't solve the problem

Offline

#6 2013-01-12 15:38:58

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,641

Re: Locale problem via SSH and X2GO

Have you found a solution? I'm also faced by this now with X2go and systemd.

Offline

#7 2013-03-11 16:06:04

hcjl
Member
From: berlin
Registered: 2007-06-29
Posts: 267

Re: Locale problem via SSH and X2GO

i found a small workaround for x2go:

on the server create a startup script for your desired WM / DE and make it executable. as an example i used gnome.

/opt/x2go/x2goserver_gnome.sh

with following content

#!/bin/bash
export LANG=de_DE.UTF-8
exec gnome-session

on the client in the appropriate session choose "other session" and enter the absolute path and filename of the script on the server.

runs like a punch in the face;-)

Offline

#8 2013-03-12 14:33:11

MAC!EK
Member
Registered: 2005-09-27
Posts: 267

Re: Locale problem via SSH and X2GO

That not the best solution but it also works for KDE:

$ cat /etc/x2go/kde_session.sh 
#!/bin/sh

export LANG=pl_PL.UTF-8
exec startkde

Offline

#9 2013-03-12 15:32:28

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,641

Re: Locale problem via SSH and X2GO

So far I got no response in the X2go mailing list. Maybe one of you should file an upstream bug.

Offline

#10 2018-09-04 17:50:32

asafg
Member
Registered: 2018-09-04
Posts: 1

Re: Locale problem via SSH and X2GO

To anyone arriving these due to similar locale problems:
As of writing these lines (Sep. 2018), X2Go server on Linux looks for /etc/profile.d/lang.sh for locale settings.
If the file is found, it is loaded upon startup. Using this file solved my problem.
The specific file that does this work is /etc/x2go/Xsession. I was using Debian under docker, it might be on a different path for ArchLinux, but I believe that it is the same script for all of the distributions.

I hope that it helped :-)

Offline

#11 2018-09-04 20:29:10

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,852
Website

Re: Locale problem via SSH and X2GO

Thanks for sharing, however, this information would be better documented on the wiki.

Mod note: Closing this old thread now.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB