You are not logged in.

#1 2012-10-21 19:50:40

From: Finland
Registered: 2012-03-18
Posts: 34

[SOLVED] No audio in XBMC after systemd upgrade

After facing and resolving the sound issues after upgrade, I thought I'd share mine resolution:

I upgraded mine XBMC setup to new systemd powered initialization (following wiki instructions)  and all seemed fine until I noticed XBMC made no sound.
Tried following without success:

- Downgrading some lately upgraded packages
- Rebooting with initscripts
- Searched for answers for error seen in journal:

 [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.DBus.Error.TimedOut: Activation of org.bluez timed out

- Removed user from audio group as instructed in some forum post (can't seem to find page anymore)

But then noticed not even aplay -l will list devices anymore. So, tried following:

sudo usermod -aG audio xbmc

Note:: The xbmc user did not belong to audio group earlier and sound was played without issue. Now after upgrade, the audio group was required.


#2 2012-10-23 03:41:32

Registered: 2010-05-19
Posts: 433

Re: [SOLVED] No audio in XBMC after systemd upgrade

Thanks for heads up but actually it is mentined on the xbmc wiki page


Board footer

Powered by FluxBB