You are not logged in.

#1 2012-10-23 14:36:16

xzy3186
Member
From: Japan
Registered: 2012-02-01
Posts: 52
Website

cairo 1.12.6-1 in testing make gnome-shell background black

Dear all,

If I upgrade cairo from 1.12.2-3/extra to 1.12.6-1/testing, background of gnome-shell overview mode will become completely black. This will also make the background of my conky be black, which is really frustrating. All the other package such as gnome-shell, xf86-video-intel, and xorg-server are from testing. The "AccelMethod" of my intel card is set to "uxa". I try to search this on google but no one seems to have same problem as mine. Is there anybody knowing how to work it around? Thanks in advance.

Best regards,
Zhengyu

Offline

#2 2012-10-29 02:02:46

jlindgren
Member
Registered: 2011-02-27
Posts: 196

Re: cairo 1.12.6-1 in testing make gnome-shell background black

Hi xzy3186,

I am also having trouble with Cairo 1.12.4 and 1.12.6 in testing, not exactly the same symptoms as you, but it's probably related.  GIMP can no longer take screenshots (they turn out completely black), and Audacious's Winamp interface is not correctly drawn.  I'm going to do a git bisect on the Cairo repository and try to find the bad commit.  IMO Cairo 1.12.6 should not be migrated to [extra] until this is resolved.

Edit: I also tried setting "NoAccel" in my xorg.conf (intel driver) with no effect.

Last edited by jlindgren (2012-10-29 02:08:03)

Offline

#3 2012-10-29 16:04:37

xzy3186
Member
From: Japan
Registered: 2012-02-01
Posts: 52
Website

Re: cairo 1.12.6-1 in testing make gnome-shell background black

@jlindgren:
Those days I am using sna as "AccelMethod". It can not solve the problem completely but better than uxa.

Offline

#4 2012-11-01 05:25:19

endived
Member
Registered: 2011-06-14
Posts: 8

Re: cairo 1.12.6-1 in testing make gnome-shell background black

Had the same issue with cairo 1.12.6; which is now in extra and came with the latest gnome-shell upgrade to 3.6.1.   I had a black background in the Activity overview.

Rolled back and pinned to cairo 1.12.2 in the meantime.   Not quite sure yet what other impact this has or what other things I might have broken.  :-)

Offline

#5 2012-11-01 06:11:46

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: cairo 1.12.6-1 in testing make gnome-shell background black

you guys should report this bug on our tracker. I don't know why was moved from testing so fast.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#6 2012-11-01 07:37:18

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: cairo 1.12.6-1 in testing make gnome-shell background black

I'm subscribed to this topic. The was no report done to either our tracker or the upstream cairo one. And after asking our gnome maintainers in IRC we agreed to move cairo since it solves other minor issues.

So get in contact with gnome and cairo project to look for the source of this issue.

Online

#7 2012-11-02 16:27:03

D4ve
Member
Registered: 2012-08-02
Posts: 209

Re: cairo 1.12.6-1 in testing make gnome-shell background black

Does each of you enabled the property "let the filemanager handle the desktop" in gnome-tweak-tool?

If yes, turn it off, upgrade cairo to the newest version and restart gnome-shell. Should fix it.

EDIT: Don't restart gnome-shell, restart the whole gdm-thing.

Last edited by D4ve (2012-11-02 16:29:47)

Offline

#8 2012-11-03 03:12:09

endived
Member
Registered: 2011-06-14
Posts: 8

Re: cairo 1.12.6-1 in testing make gnome-shell background black

D4ve wrote:

Does each of you enabled the property "let the filemanager handle the desktop" in gnome-tweak-tool?

If yes, turn it off, upgrade cairo to the newest version and restart gnome-shell. Should fix it.

EDIT: Don't restart gnome-shell, restart the whole gdm-thing.

You're not using the catalyst driver by any chance?
It seems that's what causes the behavior.   I fixed it by installing the open-source ati driver.

Offline

#9 2012-11-03 16:11:57

D4ve
Member
Registered: 2012-08-02
Posts: 209

Re: cairo 1.12.6-1 in testing make gnome-shell background black

endived wrote:

You're not using the catalyst driver by any chance?
It seems that's what causes the behavior.   I fixed it by installing the open-source ati driver.

I'm using the catalyst-driver but i need the proprietary driver for xvba-video-acceleration. Or does this work with the opensource radeon driver?

Offline

#10 2012-11-03 18:54:57

brebs
Member
Registered: 2007-04-03
Posts: 3,401

Re: cairo 1.12.6-1 in testing make gnome-shell background black

I'd recommend you try compiling cairo without --disable-xlib-xcb - fixes my font corruption with Nvidia smile

Offline

Board footer

Powered by FluxBB