You are not logged in.

#1 2012-10-23 23:21:36

From: Spain
Registered: 2012-05-04
Posts: 144

error no such device (after installation)

Dear all,
I'd like to gradually switch to Arch (from Ubuntu) so I decided to install it on a virtual machine (Virtualbox).

I followed the instructions in the "Unofficial Beginners Guide" and I thought I followed all the steps correctly.
The only thing that confused me a bit was the installation of the Virtualbox Kernel modules (to me from the guide it
is not clear if I have to install them in Ubuntu, the system from which I run the virtual machine, or in Arch the system
that is installed in the virtual machine).

Anyway I think I followed the procedure in the right way, and I didn't get any error message during the installation,
but apparently I made something wrong.

When I boot Arch, I get the GRUB menu. I select "Arch GNU/Linux with core repo kernel",
but I get this error message:

error no such device: (device id)
Loading Linux core repo...
error: no such partition
Loading initial ramdisk
error: you need to run the kernel first.
Press any key to continue...

When I press any key I get back to the GRUB menu.

If I select "Arch GNU/Linux, with core repo kernel (Fallback initramfs)"
I get the same error message.

Can you help me understanding where things might have gone wrong?

Thanks a lot in advance for your help,
and hopefully I'll join you soon in this Arch adventure smile



Board footer

Powered by FluxBB