You are not logged in.

#1 2012-10-23 23:58:19

Registered: 2012-10-23
Posts: 1

No sound with ALSA and Creative Recon3D

I have been working on this issue for several days now and still cannot get my sound card to work. Basically, I have a Creative Sound Blaster Recon3D sound card installed in a PCI slot and I am unable to play any sound through it. Note that I have the on board sound disabled in the BIOS. Also, it is my understanding that this sound card is supported as of kernel 3.5. I dual boot this system and sound does work on my Windows install. I am certain that I do not have any channels muted and that the sound card is being detected by the kernel.

I have already gone through the relevant troubleshooting steps listed in the following Wiki pages: … sound_card … leshooting

As suggested by the above pages, I have tried:
- Setting the default card in /etc/asound.conf
- Setting all instances of "card 0" to "card 2" (which is the ID of the card listed in "aplay -l") in /usr/share/alsa/alsa.conf
- Verified the sound modules were loaded
- Double checked to make sure that all channels were unmuted

A couple of interesting things I noticed:
1) Speaker-test fails:
# speaker-test -c 2

speaker-test 1.0.26

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

2) Here is some more information regarding my sound modules and hardware devices:
# lsmod | grep '^snd' | column -t
snd_hda_codec_ca0132  8244    1
snd_hda_codec_hdmi    24487   1
snd_usb_audio         102808  1
snd_hda_intel         26180   2
snd_usbmidi_lib       18744   1   snd_usb_audio
snd_rawmidi           18479   1   snd_usbmidi_lib
snd_hda_codec         98033   3   snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_ca0132
snd_seq_device        5268    1   snd_rawmidi
snd_hwdep             6300    2   snd_usb_audio,snd_hda_codec
snd_pcm               75167   4   snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc        7217    2   snd_pcm,snd_hda_intel
snd_timer             18934   1   snd_pcm
snd                   59989   17  snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_hda_codec_ca0132

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Creative [HDA Creative], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Creative [HDA Creative], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Can anyone help point me in the right direction? This is driving me crazy and I feel like I am just a few steps away from getting this working properly.

One last note, I tried going the PulseAudio route as well, and I was unsuccesful.


#2 2012-11-02 08:50:57

From: united states
Registered: 2011-02-07
Posts: 54

Re: No sound with ALSA and Creative Recon3D

I picked up a recon3d fatality for my Intel 3570K rig two weeks ago and I too cannot get sound to work to Linux. When I boot into Windows sound works of course, but no go in Linux. I did everything you did as well. It sucks. Just going to return it and pick up a Titanium HD instead.

Last edited by muffinss (2012-11-02 08:55:53)


#3 2013-03-04 22:47:17

Registered: 2013-03-04
Posts: 16

Re: No sound with ALSA and Creative Recon3D

You are trying to use the same card as me on my Alienware m14xR2.

Sound sometimes worked for me until today.

A lot of changes for this chipset is going to be published on kernel 3.9. … 02748.html


#4 2013-04-28 20:34:22

Registered: 2013-04-28
Posts: 1

Re: No sound with ALSA and Creative Recon3D

I think it's little too late now but i guess i post this for anyone searching for a fix

Recon3d works since few major kernel versions back... but there buffer allocation problem on default configuration (Card sometimes will do random loopy noice while trying to play, which means right sound data going somewhere where it does not suppose to) , it can be fixed by loading snd_hda_intel module with position_fix=1 parameter. For some reason this does not work on udev (or i'm doing something wrong tongue) so i did script:

rmmod snd_hda_intel
modprobe snd_hda_intel position_fix=1

...and i turn it to systemd service, which starts on boot and it seems to work. There 3 bugs i notice:

1. Sometime card mutes, but when i do sound is soem other application it goes back, i think there init problem or something, this seems to fixed since 3.8
2. On system wake sounds gone sometimes, guess what fix that tongue.... you need to boot Windows and go back to Linux and it works, i think this has soemthing to do with firmware
3. Optical Input does work in Audacity

3.9 inludes firmware loading which should fix lot of problems + support for What U Hear (sound loopback) and digital mic. Hopefully it also fix buffer problem

Last edited by Shadowriver (2013-04-28 20:43:09)


Board footer

Powered by FluxBB