You are not logged in.

#1 2012-10-25 17:10:52

Kotrfa
Member
Registered: 2012-10-25
Posts: 142

[SOLVED]After installation of Arch Linux system nor GRUB loads

Hi,

I tried to install Arch Linux this morning and It went terribly wrong.

The installation was relativelly good. It installed GPT, choosed packages, partitions... Everything went good - my friend was helping me, and he is very experienced of Arch linux for 4 years, we setted config files etc., but after installation we wanted to boot and nothing happened. My Samsung 530U doesnt boot and doesnt get into GRUB neither. We tried to install bootloader from installation media, but it doesnt work - nor from media, nor from the internet. I tried to install Xubuntu from live cd and I succeded, but system doesnt boot.

Can you help me out of this? Thanks

Last edited by Kotrfa (2012-10-30 10:35:48)

Offline

#2 2012-10-25 17:15:14

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,794

Re: [SOLVED]After installation of Arch Linux system nor GRUB loads

UEFI or BIOS?

Offline

#3 2012-10-25 17:17:18

Kotrfa
Member
Registered: 2012-10-25
Posts: 142

Re: [SOLVED]After installation of Arch Linux system nor GRUB loads

Yeah sorry - BIOS.

Here is my output of boot-repair. It wents succesfully and I dont get any errors. It looks (as we thought before) the GRUB files are OK, but GPT doesnt work right and dont loads GRUB stage 2.

http://paste.ubuntu.com/1305400/

Last edited by Kotrfa (2012-10-25 17:29:17)

Offline

#4 2012-10-25 17:31:31

drobole
Member
From: Norway
Registered: 2012-07-23
Posts: 123

Re: [SOLVED]After installation of Arch Linux system nor GRUB loads

Are you sure you are booting from the right disk?
If you install grub on sda you must make sure BIOS is booting from sda, not sdb

Last edited by drobole (2012-10-25 17:33:40)

Offline

#5 2012-10-25 17:40:06

Kotrfa
Member
Registered: 2012-10-25
Posts: 142

Re: [SOLVED]After installation of Arch Linux system nor GRUB loads

sdb is just my USB flash drive with Live CD of Xubuntu. Im booting sda.

I guess problem is in GPT/MBR BIOS/UEFI and I dont know how to solve it.

Last edited by Kotrfa (2012-10-25 17:46:31)

Offline

#6 2012-10-25 18:11:23

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED]After installation of Arch Linux system nor GRUB loads

Follow the Beginners' Guide. You probably missed the step where it says to install and configure a bootloader, not just install the grub-bios or syslinux package. Did you see the note about GRUB requiring a 2 MiB partition for GPT-partitioned drives on BIOS systems? Did you see the note on installing gptfdisk if you use Syslinux?

I guess not.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#7 2012-10-25 18:19:25

Kotrfa
Member
Registered: 2012-10-25
Posts: 142

Re: [SOLVED]After installation of Arch Linux system nor GRUB loads

Yes, we read it and we made as it is in guide. This is the result.

Offline

#8 2012-10-25 19:11:32

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED]After installation of Arch Linux system nor GRUB loads

Go into the BIOS, set your equivalent of "internal drive" first, "removable devices" second, and "CD-ROM" third from the boot settings. Then choose (by brand, capacity, etc) the HDD with Arch on it to boot first.

Have you tried Syslinux?


Edit: You may also try resetting the BIOS to its defaults (or to its "fail safe") settings.

Last edited by DSpider (2012-10-25 19:13:49)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#9 2012-10-27 02:55:43

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [SOLVED]After installation of Arch Linux system nor GRUB loads

@Kotrfa: Your problem looks similar to https://bbs.archlinux.org/viewtopic.php?id=151454 .

Offline

Board footer

Powered by FluxBB