You are not logged in.

#1 2012-10-27 03:16:48

masasin
Member
Registered: 2012-10-27
Posts: 5

pacstrap failed. Now I have a read-only filesystem that is unusable

Hello,

I have been using Linux for the past few years (primarily Ubuntu and Fedora), and have used the command line a lot.

I was just following the instructions on the Beginners guide. I set up wifi, and partitioned the disk using gdisk (all my computers since late 2009 have not used MBR). I then set up my mirrorlist (left the first one, and added my university as second).

When I ran pacstrap (without -i), it started downloading everything. I think it finished most of it. The kernel had been downloaded, and the filesystem supposedly set up. Then, I got an error. (I am not sure where it was, and I wasn't logging the output. There were many many lines of:

[timestamp] EXT4-fs (sda1): ext4_da_writepages: jpd2_start:8192 pages, ino xxxxxxx; err -30

Then:

[timestamp] EXT4-fs error (device sda1): ext4_journal_start_sb:370: [timestamp] EXT4-fs error (device sda1): ext4_journal_start_sb:370: [timestamp] EXT4-fs error (device sda1): Remounting filesystem read-only

error: command failed to execute correctly
error: could not create directory /mnt/var/lib/pacman/local/groff-1.21-2/: Read-only file system
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occured, no packages were upgraded.
warning: could not remove lock file /mnt/var/lib/pacman/db.lck
==> ERROR: Failed to install packages to new root
pacstrap /mnt base base-devel 35.27s user 6.19s system 3% cpu 17:34.81 total

Trying to rerun pacstrap gets me an error that the lockfile still exists. I cannot remove it because it is a "read-only filesystem". Its permissions are 000, and the folder it is in (pacman) has 755.

I also cannot make an fstab or continue with the installation.

I tried to run the setup again, and it kept failing. (MBR failed too, with the same error.)

What do you think caused it, and what could I do to resolve it. I couldn't find anything like that in the forums, or on google.

Last edited by masasin (2012-10-27 03:18:37)

Offline

#2 2012-10-27 13:51:14

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: pacstrap failed. Now I have a read-only filesystem that is unusable

Are the ext4 errors not a dead giveaway that the FS (or physical disk) are misbehaving? It's remounted itself read-only to prevent further damage.

Offline

Board footer

Powered by FluxBB