You are not logged in.

#1 2012-10-31 06:33:31

dront78
Member
From: Moscow
Registered: 2010-11-24
Posts: 38

Help required with Gnome 3 Input Sources

I used CapsLock before gnome 3.6 upgrade all working fine, however new Input Sources broke my system a little bit

I fixed my CapsLock by dconf-editor org\gnome\desktop\input-sources\xkb-options ['grp:caps_toggle', 'grp_switch', 'grp_led:caps'], but I can't get work
- language switch indicator not working
- show-flags does nothing anymore

Any help fit is required because of usability issues

Offline

#2 2012-10-31 17:34:02

mekh
Member
Registered: 2011-01-31
Posts: 11

Re: Help required with Gnome 3 Input Sources

Hi mate,
Same problem here after today's upgrade. But even dconf doesn't help me.
Waititng for solution.

Offline

#3 2012-10-31 21:09:04

lex4051
Member
From: Switzerland
Registered: 2011-08-14
Posts: 2

Re: Help required with Gnome 3 Input Sources

dront78 wrote:

I used CapsLock before gnome 3.6 upgrade all working fine, however new Input Sources broke my system a little bit

I fixed my CapsLock by dconf-editor org\gnome\desktop\input-sources\xkb-options ['grp:caps_toggle', 'grp_switch', 'grp_led:caps'], but I can't get work
- language switch indicator not working
- show-flags does nothing anymore

Any help fit is required because of usability issues

Thank you for temporary solution.

Waiting for standard solution too...

Offline

#4 2012-11-01 05:46:22

dront78
Member
From: Moscow
Registered: 2010-11-24
Posts: 38

Re: Help required with Gnome 3 Input Sources

mekh wrote:

Hi mate,
Same problem here after today's upgrade. But even dconf doesn't help me.
Waititng for solution.

you shoud disable any other input source hotkeys to make dconf "fix" works
use keyboard settings and gnome-tweak-tool to do so

Last edited by dront78 (2012-11-01 05:47:41)

Offline

#5 2012-11-02 21:50:45

ikatson
Member
Registered: 2012-08-14
Posts: 4

Re: Help required with Gnome 3 Input Sources

Also, with Gnome 3.6 it's no longer possible to switch layouts with the Caps key. That setting is not available even in gnome-tweak-tool.

I figured out how to do make the settings a lot more flexible, and fix all the layout bugs introduced by 3.6. This is done by configuring everything through setxkbmap and not letting gnome interfere with the settings.

  1. Remove all input sources, and the typing shortcuts from gnome keyboard settings window.

  2. Open dconf-editor and remove everything from "org\gnome\desktop\input-sources\xkb-options". I was not able to set it to nothing, but setting it to ['grp_led:caps'] worked. These 2 steps were needed not to interfere with the config described below.

  3. Install kbdd-git from aur, if you want separate layout for each window.

  4. Create a script with preferred setxkbmap settings. Here is mine, setting Caps to switch languages, and swapping alt and win keys on MacBook.

    #!/bin/sh
    setxkbmap -layout us,ru
    setxkbmap -option 'grp:caps_toggle'
    setxkbmap -option 'altwin:swap_lalt_lwin'
    # kbdd is needed to keep separate layout for each window.
    `which kbdd` && kbdd
  5. Launch gnome-session-properties and add this script to the list.

Last edited by ikatson (2012-11-02 21:51:13)

Offline

#6 2012-11-09 08:27:16

Perfect Gentleman
Member
Registered: 2012-10-25
Posts: 220

Re: Help required with Gnome 3 Input Sources

did anyone else try ikatson's method ?

Offline

#7 2012-11-15 12:30:14

gabell
Member
From: St. Petersburg, Russia
Registered: 2008-06-01
Posts: 6

Re: Help required with Gnome 3 Input Sources

Hi, guys. I found a more correct way to solve this issue here:

You can set the org.gnome.settings-daemon.peripherals.keyboard.input-sources-switcher setting to the desired modifier combination. gnome-tweak-tool has a UI for this setting.

Offline

Board footer

Powered by FluxBB