You are not logged in.

#1 2012-10-31 17:37:57

Registered: 2011-01-27
Posts: 25

[SOLVED] new install hangs at fsck

Hi all,

I am trying my first install on the new installation media 10-6.  Everything seemed to go smoothly until I rebooted.  Now boot hangs at Filesystem is clean. The full message I am stuck on is below.

fsck.jfs version 1.1.15, 04-Mar-2011
processing started: 10/31/2012 11:23:56
The current device is: /dev/sda3
Block size in bytes: 4096
Filesystem size in blocks: 14080972
**Phase 0 - Replay Journal Log
Filesystem is clean.

Then I have nothing.  The computer is a lenovo thinkpad t420.  Any help would be appreciated, thanks.

edit: added code tags

Last edited by rickeyski (2012-11-05 02:43:36)


#2 2012-10-31 17:47:18

Registered: 2011-01-27
Posts: 25

Re: [SOLVED] new install hangs at fsck

Some progress has been made, I manually added init=/usr/lib/systemd/systemd to the grub.cfg, now I get to

Reached target local file systems (Pre)
Mounting /tmp
Starting Load Random Seed
Started Load Kernel Modules
started Load Random Seed
Mounted /tmp
Started udev coldplug all devices

There were no failures, all messages are ok, but system won't boot.


#3 2012-11-03 13:07:36

Registered: 2006-09-23
Posts: 318

Re: [SOLVED] new install hangs at fsck

I ran into something similar yesterday.. I'm not sure it's the same problem but here's what I tried and found.

*After an unsucessful boot, restart your computer and boot off the installation media
*Mount your paritions on /mnt as you would for a fresh install.
*Run arch-chroot /mnt to chroot into your installation.
*Now you can run journalctl to see all messages logged during boot. There will be a ton of them, so hit 'G' to scroll to the bottom.
*Look for messages in red or white.

Now, in my case I found some errors from nouveau and dri. After those errors, the logs went on to show that the system fully booted, although I never got past the fsck step on the screen. A bit of searching found posts about problems with nouveau and dual graphics cards (I have on-board GPU + a Nvidia card). Some posts mentioned adding the nomodeset option to your kernel line in grub. Doing this allowed me to boot up, and after installing the nvidia driver, I was able to remove this option and still boot.

Hope this helps.

Edit: grub config with nomodeset

	echo	'Loading Linux core repo kernel ...'
	linux	/vmlinuz-linux root=UUID=e7975760-f032-438a-b38d-93bc03246e96 ro nomodeset
	echo	'Loading initial ramdisk ...'
	initrd	/initramfs-linux.img

Last edited by dmartins (2012-11-03 13:11:42)

-- Dan


#4 2012-11-05 02:48:41

Registered: 2011-01-27
Posts: 25

Re: [SOLVED] new install hangs at fsck

Thanks, the onboard and nvidia card was what was tossing it.  I disabled the nvidia card for now and no more issues.  I will go back to fight with it when I get more time.


Board footer

Powered by FluxBB