You are not logged in.

#1 2012-11-01 01:02:36

Registered: 2011-12-22
Posts: 24

Hang at boot

I updated my system to newest kernel, rebooted the pc...
It "hangs" with black screen and a single underscore blinking.
Numlock/capslock leds switch on when activated, so it isn't technically hanging but still no tty's are available and no X server.

Since I've spent 2-3hours searching the web and trying to fix the problem (with a live usb).

Grub menu doesn't show.
(before I had it with countdown=0 ie skip, but I changed it to 5 and added verbose to the kernel args).
Also by reading the logs I recal something related to gvfs permision error and thunar having a sigterm..

What I have tried doing: (chroot from live usb)
-rebuild initramfs                           
-install the earlier kernel ( [as some ppl have reported a bug 4Gigs of ram + 64bit+]
-reinstall  grub                               
-reconfigure grub
-downgrading nvidia driver 304.60.3->304.60.2 (just in case.... )

I've removed the following:

Some details about the system that might or might not be relevant:
64bit, running on i5 2500k,  8gigs ram, nvidia gtx 570.
Running Openbox + tint + gdm.

I still have no idea what happened to render the system incapable of booting...
So I need for some help figuring that out and how to solve the problem smile


#2 2012-11-01 01:06:50

From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Hang at boot

If grub doesn't load, then it may not be the system, but the bootloader.  Can you install grub (or whatever bootloader you please) onto a cd/usb and then boot the install from there?


#3 2012-11-01 12:16:46

Registered: 2011-12-22
Posts: 24

Re: Hang at boot

Ok, now I feel stupid...
I was about to re-install grub to MBR and it occured to me to check the bios boot drive sequence.

My bios had switched the drive boot sequence for some reason sad

I had problems with it before showing a msg saying "F1 for configuration restore F2 for new config...etc"
But I never had it change boot device priority before.
Maybe it's a bad battery...

So all that work for nothing...
Thanks for the suggestion though it helped narrowing down the problem smile

Btw regarding the installation of grub/syslinux on usb :

Doesn't the LiveCD have a bootloader already?
I can see an entry of "boot existing os" and by the "Tab to edit line" I'm guessing its syslinux (never used it tbh).
If so what would a standard grub boot line translate to for syslinux ?


Board footer

Powered by FluxBB