You are not logged in.

#1 2012-11-01 05:53:59

ryanmichaelmcclure
Member
From: Cloudsdale, Equestria
Registered: 2012-10-26
Posts: 44
Website

GNOME 3: File Management Default Is Baobab

I am using GNOME 3 for my desktop and AWN for a launcher. Every time I open a directory in either Cardapio or any of the default menus on AWN, Baobab opens and tries to analyze the folder. How can I set it so that Nautilus opens these? I feel as if the problem is deeper than AWN and the applets, if many do the same thing.

Removing Baobab made it so that Nautilus opened the folders, but I like to use Baobab, and reinstalling it caused the problem to come back.

Offline

#2 2012-11-01 06:06:46

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3: File Management Default Is Baobab

it happens because baobab exports the mimetype.
http://git.gnome.org/browse/baobab/comm … ab5ca6cd02

You should report that upstream and paste the link here or at least, add me to cc.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#3 2012-11-01 06:22:30

ryanmichaelmcclure
Member
From: Cloudsdale, Equestria
Registered: 2012-10-26
Posts: 44
Website

Re: GNOME 3: File Management Default Is Baobab

I'm still a Linux newbie...Incoming stupid questions.

I edited /usr/share/applications/baobab.desktop and removed

MimeType=inode/directory;

from the file. Is this what I need to do?

Also, what do you mean by report it upstream? Please excuse my ignorance.

Offline

#4 2012-11-01 06:51:15

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3: File Management Default Is Baobab

ryanmichaelmcclure wrote:

I'm still a Linux newbie...Incoming stupid questions.

I edited /usr/share/applications/baobab.desktop and removed

MimeType=inode/directory;

from the file. Is this what I need to do?

run as root update-desktop-database -q

Also, what do you mean by report it upstream? Please excuse my ignorance.

bugzilla.gnome.org


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2012-11-02 10:20:56

techryda
Member
Registered: 2012-10-01
Posts: 50

Re: GNOME 3: File Management Default Is Baobab

The fix above removes a wanted feature of baobab, namely, the ability to launch baobab from the right click menu of a folder.

I ran into this a few days back.  To fix it on a new install I run the following (Part of my install script)

## Removes nautilus.desktop from the inode/directory line (if present) and then re-adds it as the first item/default handler
# sed -i -e '/^inode\/directory/s|nautilus.desktop;||' -e '/^inode\/directory/s|=|=nautilus.desktop;|' /usr/share/applications/mimeinfo.cache
# update-mime-database /usr/share/mime

This assumes that nautilus is installed, and it makes it the systemwide default for handling directories.

This may be a FreeDesktop.org problem.  Maybe they need to allow setting priority on mimetypes for apps that should never be the default. 

What I'm thinking is that babbab would set a 'MimePriority=1' in it's .desktop file and .desktop files w/o a MimePriority (i.e. file managers) would be assumed to have a priority of 50.
Higher priorities would always be sorted first in mimeinfo.cache.

Thoughts?  Is there already a way to do what I'm suggesting, or should I file a FreeDesktop.org bug?

Last edited by techryda (2012-11-02 10:52:15)

Offline

#6 2012-11-02 11:31:43

techryda
Member
Registered: 2012-10-01
Posts: 50

Re: GNOME 3: File Management Default Is Baobab

After thinking about it, my above proposed soultion wouldn't work. 

The reason is that the MimeType line in .desktop files can contain multiple entries and its possible that you would only want to set a priority on one of them.

So, as an alternative, I think that the following could work.

instead of

MimeType=inode/directory;

in the baobab.desktop file.  It would be:

MimeType=inode/directory:1;

where the :1 is the priority for the preceding mimetype.

Edit: This still needs upstream support.  I'll file a feature request later today.

Last edited by techryda (2012-11-02 11:42:54)

Offline

#7 2012-11-02 11:41:26

techryda
Member
Registered: 2012-10-01
Posts: 50

Re: GNOME 3: File Management Default Is Baobab

And now I find: https://bugs.archlinux.org/task/31861

Admittedly, I didn't look before. smile

Offline

#8 2012-11-07 15:29:27

i18nde
Member
From: Xi'an, P.R. of China
Registered: 2011-05-16
Posts: 17

Re: GNOME 3: File Management Default Is Baobab

techryda wrote:

After thinking about it, my above proposed soultion wouldn't work. 

The reason is that the MimeType line in .desktop files can contain multiple entries and its possible that you would only want to set a priority on one of them.

So, as an alternative, I think that the following could work.

instead of

MimeType=inode/directory;

in the baobab.desktop file.  It would be:

MimeType=inode/directory:1;

where the :1 is the priority for the preceding mimetype.

Edit: This still needs upstream support.  I'll file a feature request later today.

That worked for chromium, thanks! smile But at the time inserting removable media the problem is still there. sad

EDIT: After logging out and in now everything is fine.

Last edited by i18nde (2012-11-07 16:17:37)


Strawberry fields forever!

Offline

#9 2012-11-07 16:44:12

tobsen
Member
Registered: 2011-10-13
Posts: 36

Re: GNOME 3: File Management Default Is Baobab

Seems like upstream won't fix this and each distro should provide a default mimetypes package...

Offline

Board footer

Powered by FluxBB