You are not logged in.

#1 2012-11-02 19:57:58

Registered: 2012-11-02
Posts: 1

WLAN hardblocked after 'poweroff because of low power'

Hey guys,

First of all I hope that this is the right forum to post in about my problem. If not I am sorry!!

I've got some problems with my girlfriends laptop. It's a Acer Travelmate 5542G with an Atheros AR9287 wireless card connected via PCI.

My problem is as follows:

Wireless networking worked out-of-the-box! I can connect to each network, disable an enable wireless using NetworkManager, Acer Softkeys and rfkill.
The problem only occurs if the battery power is very low and the laptop is going to supsend to disk (no difference when powered off).
When I replug the notebook and turn it on arch boots without any problem but wireless is hard-blocked (rfkill). NetworkManager only shows some information about disabled wifi-hardware.

I tried to remove and reload the wireless driver (ath9k in this case, although ath3k is also loaded???), block and unblock it using rfkill and also tried the Softkeys.
Even removing and reloading ALL ath-moduls does not show any success.
I also tried to blacklist acer_wmi (because this was a suggestion in a linux forum) but no success.
In addition I disabled pm-utils ability to power-down the wireless card (touched empty file /etc/pm/power.d/wireless).

I really hope that someone could help me because I wasn't able to find any information about this problem on different websites.

lspci | grep Net

02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
08:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

-- Edit:
On my Notebook (Acer Aspire 5740G) I got a Atheros AR928X wireless card and everything is working fine!!
-- End Edit

(sorry have to go! logfiles and more will follow tomorrow!!)

Last edited by Bl4ckH0l3 (2012-11-02 20:11:36)


Board footer

Powered by FluxBB