You are not logged in.

#1 2012-11-05 03:50:22

Registered: 2007-05-26
Posts: 105

[SOLVED]Can not find root filesystem after full upgrade

Hi Archers,

I have just upgraded my 64-bit archlinux to the newest kernel 3.6.5-1-ARCH, and I got a very strange problem now. When I reboot my PC, grub can load vmlinuz-linux and initramfs-linux.img, then I saw a black screen for 10s then it said that it can't find the root filesystem and then it dropped me to a rootfs shell and I can't do anything. I roll-back the kernel to 3.6.3 and I still got the same problem.

I rebooted my PC several times and and for once time the system boot normally without any problem. So for my PC now, I have to boot several times, if I get the error, I reboot it and I reboot until the system can boot normally.

I have separate partitions for /boot, root, /usr, /var, etc in /dev/sda harddisk. Besides I have two other harddisk /dev/sdb and /dev/sdc. My PC has 8G RAM. Here is mr grub.conf file:

menuentry 'Arch GNU/Linux, with Linux core repo kernel' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-true-5c621fbc-2148-4e53-a31e-556461eb2928' {
    set gfxpayload=keep
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos1'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  0b884927-d548-4ca5-8a51-0c758065babf
      search --no-floppy --fs-uuid --set=root 0b884927-d548-4ca5-8a51-0c758065babf
    echo    'Loading Linux core repo kernel ...'
    linux    /vmlinuz-linux root=UUID=5c621fbc-2148-4e53-a31e-556461eb2928 ro  quiet init=/usr/lib/systemd/systemd mem=8G
    echo    'Loading initial ramdisk ...'
    initrd    /initramfs-linux.img

Last edited by hungsonbk (2012-11-05 13:36:00)


#2 2012-11-05 09:43:23

From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED]Can not find root filesystem after full upgrade

First of all, please use [ code ] tags when posting code. It's easier to read this way. Secondly, I think you mean grub.cfg, not "grub.conf". My advice is to automatically generate one.

See if this helps: … onger_boot

If it doesn't, post your /etc/mkinitcpio.conf, maybe /etc/fstab too.

"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).


#3 2012-11-05 13:35:31

Registered: 2007-05-26
Posts: 105

Re: [SOLVED]Can not find root filesystem after full upgrade

I have 3 harddisks and 1 DVD with SATA connection. After reordering the SATA connections from harddisks to mainboard my Arch system can boot again normally. This is funny because it happened afer I upgraded the system. I think this is similar when I have two ethernet cards and they swap from eth0 to eth1 when I reboot the system.


Board footer

Powered by FluxBB