You are not logged in.

#1 2012-11-06 15:33:35

bassu
Member
Registered: 2011-12-21
Posts: 90

[SOLVED]iwlwifi chaos, fail to flush all queues

Having this weird problem of iwlwifi crashing, mostly happens after waking up from sleep mode or when the battery reaches 50%.

It is so random but it starts with, 'Error sending _CMD, time out after 2000ms'.
Immediately after, it tells you, 'fail to flush all tx fifo queues'
Goes on, until you see, 'Restarting adapter queue is full'.

Systemd is configured to reload iwlwifi after suspend.

Tried on/off for pcie_aspm, iwlwifi options like wd_disable, 11n_disable but ran out of any other ideas.

Did anyone else notice anything same with Intel's wireless drivers?

Last edited by bassu (2012-11-10 11:56:48)


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#2 2012-11-06 23:01:42

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: [SOLVED]iwlwifi chaos, fail to flush all queues

Update: https://bugzilla.kernel.org/show_bug.cgi?id=48921

Last edited by bassu (2012-11-06 23:02:14)


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#3 2012-11-17 09:49:39

lyman
Member
From: China
Registered: 2008-01-13
Posts: 20
Website

Re: [SOLVED]iwlwifi chaos, fail to flush all queues

solved? how?


arch x86_64 on Dell E7450

Offline

#4 2012-12-24 15:29:25

bassu
Member
Registered: 2011-12-21
Posts: 90

Re: [SOLVED]iwlwifi chaos, fail to flush all queues

lyman wrote:

solved? how?

Find the resolution here, lyman
https://wiki.archlinux.org/index.php/Th … Suspension


The greatest threat to knowledge is not ignorance - it is the illusion of knowledge!

Offline

#5 2013-10-07 01:22:38

flx.foo
Member
From: france
Registered: 2005-05-06
Posts: 2

Re: [SOLVED]iwlwifi chaos, fail to flush all queues

I had a similar problem with my: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34) wireless card in a Dell vostro v131.
A lot of : "fail to flush all tx fifo queues" and connect/disconnect from my router,
I tried a lot of different solutions with the driver options. One looks to work for me.
options iwlwifi bt_coex_active=0
(in a /etc/modprobe.d/iwlwifi.conf)
No need to disable 802.11n, it's stable... i'm able to watch a movie streaming (via pulseaudia) to a ΅sound machine" without problem.

Cheers
felix

Last edited by flx.foo (2013-10-07 01:23:47)

Offline

Board footer

Powered by FluxBB