You are not logged in.

#1 2012-11-06 20:36:50

giner
Member
Registered: 2007-02-28
Posts: 26
Website

Pacman / GLib problems happen each time when long time not upgrade

I have had this problem two or three times already. If I don't upgrade my system for a long time (last time it was a year becase I didn't use my PC) I can't do it at the end. It happens because pacman is upgraded first and then it can't be started because of old glibc.

pacman 4.0.3-3 depends on glibc>=2.15 (https://www.archlinux.org/packages/core/i686/pacman/) but actually pacman doesn't work with glibc 2.15 and that caused huge problems during upgrade. If pacman doesn't work there is nothing I can do with my system. Sure I can boot LiveCD and try to repair but that's another story.

Any ideas how to prevent such problems in future?

Offline

#2 2012-11-06 21:34:22

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,691

Re: Pacman / GLib problems happen each time when long time not upgrade

Updating your PC on a regular basis would be the best solution I can think of.  Arch systems are not meant to be left a "long time" (e.g. a whole year) without an update.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#3 2012-11-06 21:55:12

giner
Member
Registered: 2007-02-28
Posts: 26
Website

Re: Pacman / GLib problems happen each time when long time not upgrade

> Updating your PC on a regular basis would be the best solution I can think of.  Arch systems are not meant to be left a "long time" (e.g. a whole year) without an update.
Yes, for sure. But anyway would be nice to be able to upgrade pacman smoothly. I think the problem was only wrong dependency. I was able to upgade pacman (better to say I was forced to to in first) before glibc was upgraded to 2.16 and pacman became broken.

Offline

Board footer

Powered by FluxBB