You are not logged in.

#1 2012-11-08 00:05:02

delux
Member
From: Delawhere
Registered: 2012-11-02
Posts: 3

Banshee - Segmentation Faulting

Hello all! I'm running Arch with Gnome 3.6 on a (newly) systemd installation, without consolekit. I have Banshee 2.6.0 installed after the recent update, and after updating I have been getting a segmentation fault every time I start it. This typically happens within about 3 seconds of starting it up, yet it has delayed until after playing one song on occasion. Here's the output from banshee --debug:

Stacktrace:

  at (wrapper managed-to-native) Gtk.Application.gtk_main () <IL 0x0000e, 0xffffffff>
  at Gtk.Application.Run () <IL 0x00000, 0x0000b>
  at Banshee.Gui.GtkBaseClient.Run () [0x00000] in /build/src/banshee-2.6.0/src/Core/Banshee.ThickClient/Banshee.Gui/GtkBaseClient.cs:207
  at Banshee.Gui.GtkBaseClient.Startup () [0x00000] in /build/src/banshee-2.6.0/src/Core/Banshee.ThickClient/Banshee.Gui/GtkBaseClient.cs:82
  at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.CleanRoomStartup/StartupInvocationHandler) [0x00044] in /build/src/banshee-2.6.0/src/Hyena/Hyena.Gui/Hyena.Gui/CleanRoomStartup.cs:54
  at Banshee.Gui.GtkBaseClient.Startup<T> () [0x00024] in /build/src/banshee-2.6.0/src/Core/Banshee.ThickClient/Banshee.Gui/GtkBaseClient.cs:77
  at Banshee.Gui.GtkBaseClient.Startup<T> (string[]) [0x0004d] in /build/src/banshee-2.6.0/src/Core/Banshee.ThickClient/Banshee.Gui/GtkBaseClient.cs:67
  at Nereid.Client.Main (string[]) [0x00000] in /build/src/banshee-2.6.0/src/Clients/Nereid/Nereid/Client.cs:54
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <IL 0x00050, 0xffffffff>
  at (wrapper managed-to-native) System.AppDomain.ExecuteAssembly (System.AppDomain,System.Reflection.Assembly,string[]) <IL 0x0001b, 0xffffffff>
  at System.AppDomain.ExecuteAssemblyInternal (System.Reflection.Assembly,string[]) [0x00026] in /build/src/mono-2.10.8/mcs/class/corlib/System/AppDomain.cs:660
  at System.AppDomain.ExecuteAssembly (string,System.Security.Policy.Evidence,string[]) [0x00008] in /build/src/mono-2.10.8/mcs/class/corlib/System/AppDomain.cs:629
  at (wrapper remoting-invoke-with-check) System.AppDomain.ExecuteAssembly (string,System.Security.Policy.Evidence,string[]) <IL 0x0003b, 0xffffffff>
  at System.AppDomain.ExecuteAssembly (string) [0x00000] in /build/src/mono-2.10.8/mcs/class/corlib/System/AppDomain.cs:612
  at (wrapper remoting-invoke-with-check) System.AppDomain.ExecuteAssembly (string) <IL 0x00039, 0xffffffff>
  at Booter.Booter.BootClient (string) [0x00000] in /build/src/banshee-2.6.0/src/Clients/Booter/Booter/Entry.cs:112
  at Booter.Booter.Main () [0x000f1] in /build/src/banshee-2.6.0/src/Clients/Booter/Booter/Entry.cs:105
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <IL 0x0004c, 0xffffffff>

Native stacktrace:

Segmentation fault

Any suggestions on how to fix this issue? Downgrading to Banshee 2.4.1 does not help either. Thanks!


sl

Offline

#2 2012-11-08 15:05:53

uladk
Member
Registered: 2012-09-06
Posts: 9

Re: Banshee - Segmentation Faulting

I too am having this issue (Gnome 3.6, systemd). I deleted /home/*user*/.config/banshee-1 to get banshee to at least open and import my library again, but it seems very unstable. Rating songs seems to crash the player and eventually locks me out completely with a 'Segmentation fault' error in the console. I have to delete the config folder and start again after that.

Any help would be appreciated!

Offline

#3 2012-11-09 21:43:01

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Banshee - Segmentation Faulting

Confirm this bug. Banshee crashes very oftern since the major update of Gnome 3.6. Downgrading banshee to 3.4 doensn't solve the problem. So it seems to be related to Gnome 3.6.

Offline

#4 2012-11-10 06:56:45

fuchs24
Member
Registered: 2011-07-05
Posts: 5

Re: Banshee - Segmentation Faulting

https://bugs.archlinux.org/task/32390

Last edited by fuchs24 (2012-11-10 06:57:44)

Offline

#5 2012-11-10 13:44:11

ddelpino
Member
Registered: 2011-03-07
Posts: 10

Re: Banshee - Segmentation Faulting

I have my system full updated with the last kernel and Banshee fail with segmentation fault error few seconds after.

But with LTS kernel (3.0.51-1) work!!

Offline

#6 2012-11-12 18:49:53

delux
Member
From: Delawhere
Registered: 2012-11-02
Posts: 3

Re: Banshee - Segmentation Faulting

uladk wrote:

I too am having this issue (Gnome 3.6, systemd). I deleted /home/*user*/.config/banshee-1 to get banshee to at least open and import my library again, but it seems very unstable. Rating songs seems to crash the player and eventually locks me out completely with a 'Segmentation fault' error in the console. I have to delete the config folder and start again after that.

I've tried doing the same solution, and it doesn't change anything on my installation. I'm betting, as said above, that it's a problem with Gnome 3.6 sad

Last edited by delux (2012-11-12 18:50:12)


sl

Offline

#7 2012-11-15 09:45:32

dawid.loubser
Member
Registered: 2012-08-09
Posts: 18

Re: Banshee - Segmentation Faulting

Any updates on this issue? It's driving me crazy that Banshee crashes a couple of seconds after starting. The funny thing is, if you restart it a couple of times, it eventually stops crashing (for the duration of that session).

Having a terrible time with GNOME 3.6, various apps (e.g. Evolution Mail) are just totally buggy / unstable.

Offline

#8 2012-11-16 05:13:00

shmibs
Member
Registered: 2012-09-11
Posts: 91

Re: Banshee - Segmentation Faulting

/me can confirm this exact behaviour ^^
somtimes it crashes instantly, sometimes it crashes after playing a song, and, rarely, it keeps working for long periods of time (although i did have it crash once even after it had played flawlessly for an entire album).


[site] | [dotfiles] | あたしたち、人間じゃないの?

Offline

#9 2012-11-16 17:38:10

Fedes
Member
From: Buenos Aires, Argentina
Registered: 2012-10-23
Posts: 36

Re: Banshee - Segmentation Faulting

Same issue here. I tried disabling most of the extensions but no luck. Segfaulting every time a song is finished and tries to move to the next one in my Cinnamon + gnome 3.6.

Offline

#10 2012-11-27 15:20:52

uladk
Member
Registered: 2012-09-06
Posts: 9

Re: Banshee - Segmentation Faulting

Fixed for me by following the instructions by Pictuga here: http://www.pictuga.com/fiche-835.html

Download, and build the patched gconf package!

Thanks.

Last edited by uladk (2012-11-27 15:21:55)

Offline

#11 2012-11-27 18:05:37

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 392

Re: Banshee - Segmentation Faulting

uladk wrote:

Fixed for me by following the instructions by Pictuga here: http://www.pictuga.com/fiche-835.html

Download, and build the patched gconf package!

Thanks.

Thanks uladk, this fixed it for me on. Just out of curiosity, where did you find this solution?


Registered Linux user #436067

Offline

#12 2012-11-27 20:17:45

myx00r
Member
Registered: 2012-11-27
Posts: 3

Re: Banshee - Segmentation Faulting

uladk wrote:

Fixed for me by following the instructions by Pictuga here: http://www.pictuga.com/fiche-835.html

Works for me, too!
Thanks!

Offline

#13 2012-11-27 21:36:46

uladk
Member
Registered: 2012-09-06
Posts: 9

Re: Banshee - Segmentation Faulting

oboedad55 wrote:

Thanks uladk, this fixed it for me on. Just out of curiosity, where did you find this solution?

I've been checking in on this bug report where a fix was posted: https://bugs.archlinux.org/task/32390

Enjoy some tunes!

Offline

#14 2012-11-27 21:49:25

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 392

Re: Banshee - Segmentation Faulting

uladk wrote:
oboedad55 wrote:

Thanks uladk, this fixed it for me on. Just out of curiosity, where did you find this solution?

I've been checking in on this bug report where a fix was posted: https://bugs.archlinux.org/task/32390

Enjoy some tunes!

Well thanks for the eagle-eye. I was watching it too but missed it.


Registered Linux user #436067

Offline

#15 2013-01-08 07:07:07

xuedi
Member
From: Beijing
Registered: 2011-02-28
Posts: 6

Re: Banshee - Segmentation Faulting

Is this gconf patch from pictuga going into arch package any soon? does anyone has an update on this? I mean the bug was closed, but it does not seem to arrived in the packages yet ...

Last edited by xuedi (2013-01-08 07:11:27)

Offline

#16 2013-01-13 20:37:08

pictuga
Member
Registered: 2012-04-24
Posts: 6

Re: Banshee - Segmentation Faulting

they said the patch (which is from ubuntu) ain't "clean" (which is half-true, but they quote gconf's doc which is half-false), so they won't apply it in official package.
more details there https://bugs.archlinux.org/task/32927

Last edited by pictuga (2013-01-13 20:38:39)

Offline

#17 2013-02-04 10:53:51

martinbaselier
Member
Registered: 2010-06-30
Posts: 6

Re: Banshee - Segmentation Faulting

Pictuga made an updated AUR package for gconf with the patch mentioned above. found it in the bug report. Thought It should be mentioned here too.
https://aur.archlinux.org/packages/gconf-thread/
It seems to be working well. I hasn't been running this long without crashing for a long time. I even have all my usual plug-ins enabled again. wink Me happy.

Last edited by martinbaselier (2013-02-04 11:08:46)

Offline

#18 2013-03-18 10:14:06

fivedigits
Member
Registered: 2012-12-12
Posts: 13

Re: Banshee - Segmentation Faulting

Works for me too, just replace gconf with gconf-ubuntu from the AUR.

Offline

Board footer

Powered by FluxBB