You are not logged in.

#1 2012-11-08 22:02:37

steff
Member
Registered: 2009-01-08
Posts: 53

[solved]Flickering screen after resume from suspend to ram

Like subject, bottom part of the screen is flickering (starting at some line, sometimes only 1cm sometimes half the screen) but at first boot and after hibernating everything is ok, with intel graphic card, it started some week ago.
Console screen tty1-6 are also affected so no video driver issue, right? I tried downgrading kernel to mid october-state with no effect.
Booting Kubuntu everything works fine.

Thanks for any idea!

Last edited by steff (2012-12-25 19:41:33)

Offline

#2 2012-11-08 22:08:35

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [solved]Flickering screen after resume from suspend to ram

I think that if the virtual terminals are also having this, then it is a video driver issue.  Kubuntu, I assume, uses pm-utils, since they have their cray funky upstart system, so does pm-utils do something with the i915 module when it suspends?  I am of course assuming you are using systemd...

Offline

#3 2012-11-09 07:44:06

steff
Member
Registered: 2009-01-08
Posts: 53

Re: [solved]Flickering screen after resume from suspend to ram

Yes, im using systemd. I tried also downgrading xf86-video-intel to a version from some weeks ago, with no result.

PS: no difference between systemclt suspend or pm-suspend from comand line.ùù

PS2: I tried fluxbox session and there was no flickering, so it had to be something kde-session related, and I found it: it was the image pile xscreensaver, just switching to another one solved my problem.
Thanks for your interest, wonderwoofy!

Update: nothing solved, it was just temporarly by case... same issue as before...

Last edited by steff (2012-11-09 21:04:39)

Offline

#4 2012-11-10 21:00:27

steff
Member
Registered: 2009-01-08
Posts: 53

Re: [solved]Flickering screen after resume from suspend to ram

Update: it is NOT DE-related, booting to runlevel 3 and suspend from comand-line gives the same weird effect.

Last edited by steff (2012-11-10 21:00:49)

Offline

#5 2012-11-20 10:09:52

steff
Member
Registered: 2009-01-08
Posts: 53

Re: [solved]Flickering screen after resume from suspend to ram

Up. After 4 years of using arch and no format I've switched for the moment to kubuntu.
Every some day I do pacman -Syu and a test of suspending, but nothing is solved, bottom screen still flickering. Maybe I'll try a reinstall in some days.

Offline

#6 2012-12-25 19:41:10

steff
Member
Registered: 2009-01-08
Posts: 53

Re: [solved]Flickering screen after resume from suspend to ram

Today I tried e clean install, with the same result. So I studied about downgrading kernel and found while searchin in Arch Rollback Machine the linux-lts kernel

uname -r
3.0.56-1-lts

So simple...
Only issue now is  fine tuning the new install...

Offline

Board footer

Powered by FluxBB