You are not logged in.

#1 2012-11-14 23:02:25

Milky Way
Registered: 2007-12-16
Posts: 6

gnome bluetooth timeout.

Sine i've updated to gnome 3.6 i can no longer browse files on a bluetooth device due to a dbus timeout.

Error browsing device

The requested device can not be browsed, error is 'Gio.DBusError: Message did not receive a reply (timeout by message bus)'

My google search seems to favor 2009 with the pages it finds about bluetooth errors on linux.
Reading trough some of those pages an permission error with obex-data-server shows up quite a few times. And indeed trying to run obex-data-server from the command line gave the same error on my machine:

Connection ":1.19" is not allowed to own the service "org.openobex" due to security policies in the configuration file

Adding a dbus configuration file to allow taking ownership of org.openobex:


  <policy context="default">
    <allow own_prefix="org.openobex"/>


allows obex-data-server to run without error on the command line, but gnome-bluetooth/nautilus still times out when trying to browse the device.

dbus-monitor produces the following output when trying to browse a device:

The only thing that shows up in the logs (journalctl) is an error from obex-data-server:

Nov 14 23:21:49 mike-laptop obex-data-server[679]: sdp_extract_seqtype: Unexpected end of packet

Maybe there are still some permission issues with obex and dbus?

Does anyone know what could be causing this?


#2 2012-11-15 22:16:17

Milky Way
Registered: 2007-12-16
Posts: 6

Re: gnome bluetooth timeout.

I've tracked it down to a problem with gvfs-obexftp, there aren't any problems when downgrading to gvfs-obexftp version 1.12.3.


#3 2012-11-16 13:22:20

Registered: 2011-05-16
Posts: 23

Re: gnome bluetooth timeout.

I have been experiencing the same problem recently. I can confirm that, in my case as well, this was fixed by downgrading back to version 1.12.3.
Thanks for posting this!


#4 2012-12-04 14:14:46

Registered: 2012-06-21
Posts: 9

Re: gnome bluetooth timeout.

I can confirm that downgrading to packages:


Solved the problem when gnome bluetooth settings dialog was giving "Unable to mount OBEX volume" message when trying to browse files.
It is kind of sad because 1.12.3 is quite a history... do they know they have a bug?


Board footer

Powered by FluxBB