You are not logged in.

#1 2012-11-15 17:14:32

Registered: 2009-02-04
Posts: 47

Problems in Arch as guest in VMware Player

I'm running a fully updated Arch installation without a graphical interface in VMware Player 5, with Windows 7 as host. I've installed open-vm-tools from the repository, created the /etc/arch-release file and appended the daemon open-vm-tools to rc.conf as mentioned in the wiki. But every time I open the virtual machine I'm greeted with the warning:

The VMware Tools resume script did not run successfully in this virtual machine.
If you have configured a custom resume script in this virtual machine, make sure that it contains no errors.
You can also submit a support request to report this issue.

I don't even know where the resume script is and I'm pretty sure I haven't customized it. But as the machine boots correctly, I tried continuing and sharing a folder with the host.

I've set to share my Windows desktop in VMware player, set as "Always enabled" and with name "desktop". I tried mounting this folder adding the following line in /etc/fstab:

.host:/desktop /home/boppreh/desktop vmhgfs defaults 0 0

and the following commands

mount -t vmhgfs .host:/desktop ~/desktop


mount -t -v -o rw .host:/desktop ~/desktop

Those two commands print the message "Could not add entry to mtab, continuing".

All of them result in the same weird behavior: whenever I try to access the ~/desktop directory, I get kicked out back to Arch's login screen. I tried piping the output of those commands to a file, so I could see the error, but it never writes anything. It happens when I cd to the directory, or a simple ls.

So what's going on here? Is there any problem with the default resume script? Maybe open-vm-tools requires some kind of graphical access but didn't bother to tell? Did I do something wrong or forgot any step?


#2 2012-11-15 18:04:34

Registered: 2009-02-04
Posts: 47

Re: Problems in Arch as guest in VMware Player

Solved the problem with the "resume script did not run successfully" warning by using the systemd specific configuration: … systemd%29

The shared folders still kick me out, though, even after following the Shared Folders instructions in the wiki for systemd. When running the mount command the folder is added correctly to /etc/mtab, even though the "Could not add entry to mtab, continuing" warning persists. I just tried cd-ing in the mounted directory as root, and it seems to work. Running commands as "sudo" doesn't help, I have to su first and then navigate to the directory to see its contents. Changing the permission of the folder didn't help either.

I'm thinking of just serving the files in a webserver. This is way too much work and by the number of strange problems it looks like I'm not supposed to be doing this.

Edit: exploring the shared folder as root works, but coping the files hangs the entire machine. Yeah, I'm going with the webserer alternative for now. If anyone has experienced this problems before, please share your ideas.

Last edited by BoppreH (2012-11-15 18:16:30)


Board footer

Powered by FluxBB