You are not logged in.

#1 2012-11-18 10:09:47

Registered: 2008-12-18
Posts: 10

[Solved] systemd and fstab with /var bind

I'm having some troubles migrating to systemd. I have the following in my fstab:

# /etc/fstab: static file system information
# <file system> <dir>   <type>  <options>       <dump>  <pass>
tmpfs           /tmp    tmpfs   nodev,nosuid,size=8G    0       0
UUID=2bedbb1a-015f-4c46-ab48-f3ffc55b154b /boot ext2 defaults 0 1
#UUID=2c5f02a3-c8a1-45ed-92f4-dc09e56c09d7 /var ext4 discard,noatime 0 1
UUID=2c5f02a3-c8a1-45ed-92f4-dc09e56c09d7 /mnt/mythtv ext4 discard,noatime 0 1
UUID=910898cb-2d67-4689-ba51-358d94b2531d swap swap defaults 0 0
UUID=cac6ccea-456a-4c09-a1db-57cec02b238d / ext4 discard,noatime 0 1
/dev/mapper/VolGroupArray-lvmedia /mnt/media ext4 auto 0 0
mnt/media/var /var bind defaults,bind 0 0

(/dev/sda is an ssd disk so I decided to move /var to my software raid and lvm disks)
However this doesn't seem to work anymore with systemd as it doesn't get mounted automatically anymore. I've setup a debug console, there I can mount it by simply typing mount /var and then I can manually start the services that failed.


didn't actually solve the bind stuff, but decided to make a new partition on the lvm disk and mount /var there.

Last edited by blahbla77 (2012-11-18 13:58:13)


#2 2012-11-18 15:13:22

From: New York, USA
Registered: 2009-10-22
Posts: 4,109

Re: [Solved] systemd and fstab with /var bind

Are you really missing a leading / from the last line?


Board footer

Powered by FluxBB