You are not logged in.

#1 2012-11-20 17:03:59

dunric29a
Member
Registered: 2005-12-16
Posts: 23

Thunar volume mounting issue

Hi,

based on a wiki I did added x-gvfs-show option to /etc/fstab entry to enable mounting also with Thunar volume manager:

/dev/sdb1       /mnt/memory auto noauto,rw,user,x-gvfs-show  0 0

After inserting an USB flash drive it gets automounted in Thunar but with root not with the current user ownership. So the user option is unexpectedly ignored. There is also no appropriate message in .xsession-errors log file.
The device can be mounted correctly in shell with mount /mnt/memory .
If I remove above record for /dev/sdb1 in fstab completely, the device is automounted with correct ownerships.

  • How to configure gvfs to accept all fstab mount options ?

  • Where can I find some documentation concerning gvfs and available fstab options (x-gvfs-show, x-gvfs-name, ...) ?

Offline

#2 2012-11-20 20:24:30

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: Thunar volume mounting issue

The wiki has some good information. smile


Arch Linux Wiki - FSTAB

Arch Linux Wiki - Thunar


Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

Board footer

Powered by FluxBB