You are not logged in.

#1 2012-11-21 17:52:50

thms
Member
Registered: 2010-02-01
Posts: 117

KDE: Poweroff and Reboot don't work anymore

Since some weeks I have a systemd only system and the migration from initscript went fine (thanks guys for the excellent wiki).

I now have a problem with KDE that occurred yesterday: When I click on Poweroff or Reboot in the "Leave Menu" nothing happens. I therefore use poweroff from terminal.  I tried the solution described at the end of this thread but with no success. https://bbs.archlinux.org/viewtopic.php?id=152610

Any ideas?

Offline

#2 2012-11-21 18:05:11

bgc1954
Member
From: Edmonton, AB, Canada
Registered: 2006-03-14
Posts: 1,124

Re: KDE: Poweroff and Reboot don't work anymore

Did poweroff or reboot work before yesterday?
Did you do a system upgrade yesterday?
Do you have systemd-sysvcompat installed--as linked to in the post you linked to?
There are many posts about shutdown and reboot buttons not working in other de, wm's not only KDE, have you tried other solutions?

Last edited by bgc1954 (2012-11-21 18:05:47)


Time is a great teacher, but unfortunately it kills all its pupils ... - Louis Hector Berlioz

Offline

#3 2012-11-21 18:14:50

thms
Member
Registered: 2010-02-01
Posts: 117

Re: KDE: Poweroff and Reboot don't work anymore

Yes, it worked before and yes I made an update. I went through the pacman.log but there're no .pacnew
Yes, systemd-sysvcompat is also installed.

For the threads concerning the other DEs: I will look at them smile

Offline

#4 2012-11-24 15:19:07

thms
Member
Registered: 2010-02-01
Posts: 117

Re: KDE: Poweroff and Reboot don't work anymore

Ok, I didn't find a solution. What I'm wondering about is, that sleep and hibernate work from the "Leave Menu".

For some people, polkit was the problem but it is running fine:

# systemctl status polkit.service
polkit.service - Authorization Manager
          Loaded: loaded (/usr/lib/systemd/system/polkit.service; static)
          Active: active (running) since Sat, 2012-11-24 16:08:37 CET; 19min ago
            Docs: man:polkit(8)
        Main PID: 540 (polkitd)
          CGroup: name=systemd:/system/polkit.service
                  └ 540 /usr/lib/polkit-1/polkitd --no-debug

Nov 24 16:08:37 molungus systemd[1]: Starting Authorization Manager...
Nov 24 16:08:37 molungus polkitd[540]: Started polkitd version 0.107
Nov 24 16:08:37 molungus polkitd[540]: Loading rules from directory /etc/polkit-1/r....d
Nov 24 16:08:37 molungus polkitd[540]: Loading rules from directory /usr/share/polk....d
Nov 24 16:08:37 molungus polkitd[540]: Finished loading, compiling and executing 1 rules
Nov 24 16:08:37 molungus polkitd[540]: Acquired the name org.freedesktop.PolicyKit1...us
Nov 24 16:08:37 molungus systemd[1]: Started Authorization Manager.

And I'm already using kdm instead of lightdm

Last edited by thms (2012-11-24 15:30:26)

Offline

#5 2012-11-28 16:57:07

thms
Member
Registered: 2010-02-01
Posts: 117

Re: KDE: Poweroff and Reboot don't work anymore

I guess this is related to my problem:

When I try to change settings under System Settings -> Login Screen I'm not longer asked for my root password but I get the error message

Unable to authenticate/execute the action: (code 4)

polkit-kde is installed

Offline

#6 2012-12-04 10:51:23

thms
Member
Registered: 2010-02-01
Posts: 117

Re: KDE: Poweroff and Reboot don't work anymore

What additional information is needed to solve this issue?

Offline

#7 2012-12-04 18:38:15

bgc1954
Member
From: Edmonton, AB, Canada
Registered: 2006-03-14
Posts: 1,124

Re: KDE: Poweroff and Reboot don't work anymore

Maybe try

$ loginctl

then use the session number it shows and do

$ loginctl show-session 1

where 1 or some other number is the session shown from loginctl.  This should show you that your session is active.  If not, then for some reason systemd-logind isn't starting properly from kdm.  It seems that most of the other posts that were having trouble solved it by using kdm, but unfortunately this doesn't seem to be your case.

Also, while you're at it try

$ systemctl

and check for any failed units or problems.  It still seems like your systemd-logind isn't starting up properly.

Last edited by bgc1954 (2012-12-04 18:38:48)


Time is a great teacher, but unfortunately it kills all its pupils ... - Louis Hector Berlioz

Offline

#8 2012-12-05 09:52:43

ToxinPowe
Member
Registered: 2010-11-26
Posts: 20

Re: KDE: Poweroff and Reboot don't work anymore

#Thms

Same problem here and same message on systemsettings-login screen. I'm on 4.10 beta1.

Offline

#9 2012-12-05 13:53:13

gnumdk
Member
Registered: 2009-10-15
Posts: 110

Re: KDE: Poweroff and Reboot don't work anymore

Do you have systemd-sysvcompat installed ?

$ grep tCmd /usr/share/config/kdm/kdmrc

Offline

#10 2012-12-05 14:24:32

ToxinPowe
Member
Registered: 2010-11-26
Posts: 20

Re: KDE: Poweroff and Reboot don't work anymore

#gnumdk

grep tCmd /usr/share/config/kdm/kdmrc
#HaltCmd=
#RebootCmd=

I have systemd-sysvcompat installed

Offline

#11 2012-12-05 14:25:52

thms
Member
Registered: 2010-02-01
Posts: 117

Re: KDE: Poweroff and Reboot don't work anymore

bgc1954:
It seems that the session is active:

$ loginctl show-session 1
Id=1
Timestamp=Mi, 2012-12-05 15:14:42 CET
TimestampMonotonic=18460508
DefaultControlGroup=name=systemd:/user/thomas/1
VTNr=7
Display=:0
Remote=no
Service=kde-np
Leader=413
Audit=1
Type=x11
Class=user
Active=yes
State=active
KillProcesses=no
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
Name=thomas 

with systemctl I couldn't find any failed unit (same with systemctl --failed)

ToxinPowe: I'm still on 4.9.3

gnumdk:

$ pacman -Qs systemd-sysvcompat
local/systemd-sysvcompat 196-2 (base)
    sysvinit compat for systemd
$ grep tCmd /usr/share/config/kdm/kdmrc
HaltCmd=/sbin/poweroff
RebootCmd=/sbin/shutdown -r now

Offline

#12 2012-12-05 14:46:34

ToxinPowe
Member
Registered: 2010-11-26
Posts: 20

Re: KDE: Poweroff and Reboot don't work anymore

Okay, I edited my /usr/share/config/kdm/kdmrc (.pacnew before) to:
HaltCmd=/sbin/shutdown -h -P now
RebootCmd=/sbin/shutdown -r now

and is working again, thank you guys wink

Offline

#13 2012-12-05 14:48:19

thms
Member
Registered: 2010-02-01
Posts: 117

Re: KDE: Poweroff and Reboot don't work anymore

ToxinPowe wrote:

Okay, I edited my /usr/share/config/kdm/kdmrc (.pacnew before) to:
HaltCmd=/sbin/shutdown -h -P now
RebootCmd=/sbin/shutdown -r now

and is working again, thank you guys wink

And why isn't this working for me?

Offline

#14 2012-12-05 14:51:34

ToxinPowe
Member
Registered: 2010-11-26
Posts: 20

Re: KDE: Poweroff and Reboot don't work anymore

I don't know hmm

Offline

#15 2012-12-05 15:47:27

bgc1954
Member
From: Edmonton, AB, Canada
Registered: 2006-03-14
Posts: 1,124

Re: KDE: Poweroff and Reboot don't work anymore

@thms - My only other suggestion would be to try and create a new user and see if that helps your situation.  Perhaps an individual setting somewhere is preventing your buttons from working?

Or maybe try and set your kdmrc to systemctl poweroff, and systemctl reboot instead of the sbin symlinks?

Last edited by bgc1954 (2012-12-05 15:49:43)


Time is a great teacher, but unfortunately it kills all its pupils ... - Louis Hector Berlioz

Offline

#16 2012-12-05 16:46:25

thms
Member
Registered: 2010-02-01
Posts: 117

Re: KDE: Poweroff and Reboot don't work anymore

This is weird. Under a new user everything works fine. I just moved my .kde4 to another location and the problem is solved.

I always thought shutdown, restart and so on are system wide things. Still confused what could have touched my KDE settings this way.

\edit: Reboot still doesn't work...the computer just hangs with a black screen and a flashing cursor.

Last edited by thms (2012-12-05 16:55:26)

Offline

#17 2012-12-05 17:06:14

bgc1954
Member
From: Edmonton, AB, Canada
Registered: 2006-03-14
Posts: 1,124

Re: KDE: Poweroff and Reboot don't work anymore

Does systemctl reboot work in a terminal?  If it does did you change your kdmrc?

I understand your confusion but every once in a while when I peruse through forums I see DE's behaving strangely until someone tries a new user.  Don't know why it works but it seems to help sometimes. smile

Last edited by bgc1954 (2012-12-05 17:08:13)


Time is a great teacher, but unfortunately it kills all its pupils ... - Louis Hector Berlioz

Offline

Board footer

Powered by FluxBB