You are not logged in.

#1 2012-11-28 09:06:10

Registered: 2011-08-03
Posts: 68

Xmodmap F13 issue


I am trying to remap my Caps Lock key to F13 using xmodmap. About a year ago this was working flawlessly when I was using Ratpoison. My .Xmodmap looks like this:

remove Lock = Caps_Lock
keycode 66 = F13

With the above configuration, once my X session starts, two odd things, and one normal thing happen. First, what's normal is that Caps Lock is disabled. The odd things, are that my system "beeps" when F13 (what was Caps_Lock) is pressed, and when I'm in a terminal it creates a '~' symbol. In insert mode using GVim, it prints '<F13>'. I have set up a keybind in my Openbox rc.xml to test the functionality of my new F13 key, but it isn't working. I generated a file of my entire keymap using xmodmap, and F13 was not listed as being used by any other keycode on the system before I began. I tried the following:

remove Lock = Caps_Lock
keycode 66 =

and Caps Lock is disabled, and the key appears to do nothing (as intended.) Does anyone know what is up with my F13 key? I would like to use it as an 'escape' key for my Openbox keybindings.

Edit: Tried another way, with the same results as previously posted.

clear Lock
keysym Caps_Lock = F13

Last edited by rogue (2012-11-29 01:44:19)


Board footer

Powered by FluxBB