You are not logged in.

#1 2012-11-28 21:44:41

letian_north
Member
Registered: 2012-11-28
Posts: 18

[SOLVED] "halt" does not shutdown laptop

When issuing "halt", I receive the following messages:

Sending SIGTERM to remaining processes...
Sending SIGKILL to remaining processes...
Unmounted file systems.
Unmounted /dev/mqueue
Unmounted /sys/kernel/debug.
Unmounted /dev/hugepages.
Disabling swaps.
Detaching loop devices.
Detaching DM devices.
System halted

the laptop do not turn off.
I honestly don't want to experiment with kernel options here, I need my acpi working as it did before. I have never had such issue with arch on my machine. This happened after I reinstalled the system with the latest iso.

Last edited by letian_north (2012-11-28 21:52:07)

Offline

#2 2012-11-28 21:45:59

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [SOLVED] "halt" does not shutdown laptop

Offline

#3 2012-11-28 21:50:59

letian_north
Member
Registered: 2012-11-28
Posts: 18

Re: [SOLVED] "halt" does not shutdown laptop

uh, systemd.

Just tested. The following commands worked for me:

# systemctl poweroff
# halt -p
# shutdown -h now

Last edited by letian_north (2012-11-28 21:51:53)

Offline

#4 2012-11-28 23:35:34

ego.abyssi
Member
Registered: 2011-07-27
Posts: 45

Re: [SOLVED] "halt" does not shutdown laptop

Technically, isn't that what halt is supposed to do?  Just halt the processor after bringing down services?


Fortune sides with him who dares -Virgil

Offline

#5 2012-11-28 23:38:33

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [SOLVED] "halt" does not shutdown laptop

ego.abyssi wrote:

Technically, isn't that what halt is supposed to do?  Just halt the processor after bringing down services?

Exactly.

Offline

Board footer

Powered by FluxBB