You are not logged in.

#1 2012-11-29 09:43:59

Registered: 2011-10-05
Posts: 166

[SOLVED] ssh-passphrase not recognized by ssh-agent

After an upgrade yesterday, I cannot enter my system anymore. It boots with some (rapidly passing) error messages (related to AF_UNIX) and shows me the login prompt. But fontsize isn't the one I had before, and customized keymappings of my keyboard are missing. Thus my configurations for the console have not been read.

Then I can successfully enter my login and password - but not the ssh-passphrase asked for by ssh-agent. I typed it many times, it must be correct, but is not recognized anymore. So at this point I'm stuck. I rebooted and tried fallback Arch - with the same result.

Then I chose the grub> shell during boot, and tab gave me a list of available commands. But I don't know what to do now.

So my question is:
how can I enter my system besides the ssh-passphrase problem? And if I managed to get into the system again - what might be the cause of this problem?

Ok, I tried to enter my pass-phrase as if I had an US keyboard (I have a German keyboard) and that worked. Now I can enter my system again, so I close this question. Maybe I will open another question soon, related to the root-cause of the problem (why my configuration isn't loaded on startup).

Last edited by 4on6 (2012-11-29 11:35:01)


Board footer

Powered by FluxBB