You are not logged in.

#1 2012-11-30 19:47:10

colbert
Member
Registered: 2007-12-16
Posts: 809

[SOLVED]External drive (SATA in enclosure) not showing up (USB)

I have had my drive working for ages, but recently it has stopped showing up in fdisk -l. dmesg shows some detection but I think it's something to do with systemd, which I switched over to recently coinciding with this.

dmesg on plugging drive in:

[393067.614072] usb 2-2: new high-speed USB device number 5 using ehci_hcd
[393412.238224] usb 2-2: USB disconnect, device number 5
[393428.780693] usb 1-6: new high-speed USB device number 10 using ehci_hcd

Also systemctl output:

└─> systemctl
UNIT                                                                                     LOAD   ACTIVE SUB       DESCRIPTION
proc-sys-fs-binfmt_misc.automount                                                        loaded active running   Arbitrary Executable File Formats File System Automount Point
sys-devices-pci0000:00-0000:00:1c.5-0000:02:00.0-net-eth0.device                         loaded active plugged   88E8056 PCI-E Gigabit Ethernet Controller
sys-devices-pci0000:00-0000:00:1e.0-0000:05:01.0-sound-card0.device                      loaded active plugged   VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller
sys-devices-pci0000:00-0000:00:1f.2-ata4-host3-target3:0:0-3:0:0:0-block-sda-sda1.device loaded active plugged   OCZ-VERTEX4
sys-devices-pci0000:00-0000:00:1f.2-ata4-host3-target3:0:0-3:0:0:0-block-sda-sda2.device loaded active plugged   OCZ-VERTEX4
sys-devices-pci0000:00-0000:00:1f.2-ata4-host3-target3:0:0-3:0:0:0-block-sda-sda3.device loaded active plugged   OCZ-VERTEX4
sys-devices-pci0000:00-0000:00:1f.2-ata4-host3-target3:0:0-3:0:0:0-block-sda-sda5.device loaded active plugged   OCZ-VERTEX4
sys-devices-pci0000:00-0000:00:1f.2-ata4-host3-target3:0:0-3:0:0:0-block-sda-sda6.device loaded active plugged   OCZ-VERTEX4
sys-devices-pci0000:00-0000:00:1f.2-ata4-host3-target3:0:0-3:0:0:0-block-sda-sda7.device loaded active plugged   OCZ-VERTEX4
sys-devices-pci0000:00-0000:00:1f.2-ata4-host3-target3:0:0-3:0:0:0-block-sda.device      loaded active plugged   OCZ-VERTEX4
sys-devices-pci0000:00-0000:00:1f.2-ata5-host4-target4:0:0-4:0:0:0-block-sdb-sdb1.device loaded active plugged   ST32000641AS
sys-devices-pci0000:00-0000:00:1f.2-ata5-host4-target4:0:0-4:0:0:0-block-sdb.device      loaded active plugged   ST32000641AS
sys-devices-pci0000:00-0000:00:1f.2-ata6-host5-target5:0:0-5:0:0:0-block-sdc-sdc1.device loaded active plugged   SAMSUNG_HD154UI
sys-devices-pci0000:00-0000:00:1f.2-ata6-host5-target5:0:0-5:0:0:0-block-sdc.device      loaded active plugged   SAMSUNG_HD154UI
sys-devices-pci0000:00-0000:00:1f.2-ata7-host6-target6:0:0-6:0:0:0-block-sr0.device      loaded active plugged   PIONEER_DVD-RW_DVR-212D
sys-devices-pci0000:00-0000:00:1f.2-ata8-host7-target7:0:0-7:0:0:0-block-sdd-sdd1.device loaded active plugged   WDC_WD1001FALS-00J7B0
sys-devices-pci0000:00-0000:00:1f.2-ata8-host7-target7:0:0-7:0:0:0-block-sdd.device      loaded active plugged   WDC_WD1001FALS-00J7B0
sys-devices-platform-serial8250-tty-ttyS1.device                                         loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS1
sys-devices-platform-serial8250-tty-ttyS2.device                                         loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS2
sys-devices-platform-serial8250-tty-ttyS3.device                                         loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS3
sys-devices-pnp0-00:09-tty-ttyS0.device                                                  loaded active plugged   /sys/devices/pnp0/00:09/tty/ttyS0
sys-module-fuse.device                                                                   loaded active plugged   /sys/module/fuse
sys-subsystem-net-devices-eth0.device                                                    loaded active plugged   88E8056 PCI-E Gigabit Ethernet Controller
-.mount                                                                                  loaded active mounted   /
dev-hugepages.mount                                                                      loaded active mounted   Huge Pages File System
dev-mqueue.mount                                                                         loaded active mounted   POSIX Message Queue File System
home.mount                                                                               loaded active mounted   /home
media-newpics.mount                                                                      loaded active mounted   /media/newpics
media-stuff.mount                                                                        loaded active mounted   /media/stuff
media-video.mount                                                                        loaded active mounted   /media/video
media-win7.mount                                                                         loaded active mounted   /media/win7
proc-sys-fs-binfmt_misc.mount                                                            loaded active mounted   Arbitrary Executable File Formats File System
run-user-1000-gvfs.mount                                                                 loaded active mounted   /run/user/1000/gvfs
sys-fs-fuse-connections.mount                                                            loaded active mounted   FUSE Control File System
sys-kernel-debug.mount                                                                   loaded active mounted   Debug File System
tmp.mount                                                                                loaded active mounted   Temporary Directory
cups.path                                                                                loaded active running   CUPS Printer Service Spool
systemd-ask-password-console.path                                                        loaded active waiting   Dispatch Password Requests to Console Directory Watch
systemd-ask-password-wall.path                                                           loaded active waiting   Forward Password Requests to Wall Directory Watch
avahi-daemon.service                                                                     loaded active running   Avahi mDNS/DNS-SD Stack
colord.service                                                                           loaded active running   Manage, Install and Generate Color Profiles
console-kit-daemon.service                                                               loaded active running   Console Manager
console-kit-log-system-start.service                                                     loaded active exited    Console System Startup Logging
cronie.service                                                                           loaded active running   Periodic Command Scheduler
cups.service                                                                             loaded active running   CUPS Printing Service
dbus.service                                                                             loaded active running   D-Bus System Message Bus
getty@tty1.service                                                                       loaded active running   Getty on tty1
getty@tty2.service                                                                       loaded active running   Getty on tty2
lm_sensors.service                                                                       loaded active exited    Initialize hardware monitoring sensors
mysqld.service                                                                           loaded active running   MySQL Server
network.service                                                                          loaded active running   LEGACY unit for "network" rc script
nmbd.service                                                                             loaded active running   Samba NetBIOS name server
ntpd.service                                                                             loaded active running   Network Time Service
polkit.service                                                                           loaded active running   Authorization Manager
rc-local.service                                                                         loaded active exited    /etc/rc.local Compatibility
sickbeard.service                                                                        loaded active running   SickBeard Daemon
smbd.service                                                                             loaded active running   Samba SMB/CIFS server
sshd.service                                                                             loaded active running   OpenSSH Daemon
systemd-journald.service                                                                 loaded active running   Journal Service
systemd-logind.service                                                                   loaded active running   Login Service
systemd-modules-load.service                                                             loaded failed failed    Load Kernel Modules
systemd-remount-fs.service                                                               loaded active exited    Remount Root and Kernel File Systems
systemd-sysctl.service                                                                   loaded active exited    Apply Kernel Variables
systemd-tmpfiles-setup.service                                                           loaded active exited    Recreate Volatile Files and Directories
systemd-udev-trigger.service                                                             loaded active exited    udev Coldplug all Devices
systemd-udevd.service                                                                    loaded active running   udev Kernel Device Manager
systemd-user-sessions.service                                                            loaded active exited    Permit User Sessions
systemd-vconsole-setup.service                                                           loaded active exited    Setup Virtual Console
timidity.service                                                                         loaded active running   TiMidity++ Daemon
udisks.service                                                                           loaded active running   UDisks
udisks2.service                                                                          loaded active running   Disk Manager
upower.service                                                                           loaded active running   Daemon for power management
avahi-daemon.socket                                                                      loaded active listening Avahi mDNS/DNS-SD Stack Activation Socket
cups.socket                                                                              loaded active running   CUPS Printing Service Sockets
dbus.socket                                                                              loaded active running   D-Bus System Message Bus Socket
systemd-initctl.socket                                                                   loaded active listening /dev/initctl Compatibility Named Pipe
systemd-journald.socket                                                                  loaded active running   Journal Socket
systemd-shutdownd.socket                                                                 loaded active listening Delayed Shutdown Socket
systemd-udevd-control.socket                                                             loaded active running   udev Control Socket
systemd-udevd-kernel.socket                                                              loaded active running   udev Kernel Socket
dev-sda5.swap                                                                            loaded active active    /dev/sda5
arch-daemons.target                                                                      loaded active active    Arch Daemons
basic.target                                                                             loaded active active    Basic System
cryptsetup.target                                                                        loaded active active    Encrypted Volumes
getty.target                                                                             loaded active active    Login Prompts
graphical.target                                                                         loaded active active    Graphical Interface
local-fs-pre.target                                                                      loaded active active    Local File Systems (Pre)
local-fs.target                                                                          loaded active active    Local File Systems
multi-user.target                                                                        loaded active active    Multi-User
remote-fs.target                                                                         loaded active active    Remote File Systems
sockets.target                                                                           loaded active active    Sockets
sound.target                                                                             loaded active active    Sound Card
swap.target                                                                              loaded active active    Swap
sysinit.target                                                                           loaded active active    System Initialization
systemd-tmpfiles-clean.timer                                                             loaded active waiting   Daily Cleanup of Temporary Directories

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

95 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

Drive has always been NTFS and no issues, so not sure what's going on. I also just plugged it into my Win 7 laptop and it was detected and I'm reading/writing to it. Appreciate any help!

Edit: I also used it just fine in my Win7 dual boot on same computer.

Last edited by colbert (2012-12-03 19:57:31)

Offline

#2 2012-11-30 23:08:21

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED]External drive (SATA in enclosure) not showing up (USB)

Had you updated the kernel and not rebooted?

Offline

#3 2012-12-03 19:57:18

colbert
Member
Registered: 2007-12-16
Posts: 809

Re: [SOLVED]External drive (SATA in enclosure) not showing up (USB)

Yeah it is working now, it may have been a reboot smile Thanks!

Offline

Board footer

Powered by FluxBB