You are not logged in.

#1 2012-12-01 21:28:45

Potomac
Member
Registered: 2011-12-25
Posts: 311

[SOLVED] Firefox 17.0.1 not really updated

I have archlinux 32 bits and I use firefox,

I notice despite the installation of the firefox 17.0.1 package my version of firefox is still 17.0 ( file date is 20 nov 2012 in /usr/lib/firefox but it should be 1 dec 2012 ),

is it normal ?

I tried to reinstall the firefox package ( pacman -S firefox ) but it seems that I have still the 17.0 version when I check the version in firefox menu,

when I type "pacman -Q firefox" I have :

firefox 17.0-1

but I am sure it's not the 17.0.1 version who is installed in my system ( because of the file date, 20 nov instead of 1 dec )

Last edited by Potomac (2012-12-01 21:52:30)

Offline

#2 2012-12-01 21:37:58

Shinto
Member
Registered: 2012-07-27
Posts: 66

Re: [SOLVED] Firefox 17.0.1 not really updated

Well, are you judging only by the file date?

If so, what does firefox -v say?
Mine says

Mozilla Firefox 17.0.1

Everything's fine here.

Edit: Nevermind. Should read more properly. lol

Last edited by Shinto (2012-12-01 21:38:57)

Offline

#3 2012-12-01 21:41:54

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [SOLVED] Firefox 17.0.1 not really updated

Update your /etc/pacman.d/mirrorlist, run 'pacman -Syy' and re-run pacman to check for updates. You may want to install 'reflector' from [community] to get an up-to-date list of mirrors. Run 'reflector -h' to learn more about its options.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#4 2012-12-01 21:49:35

Potomac
Member
Registered: 2011-12-25
Posts: 311

Re: [SOLVED] Firefox 17.0.1 not really updated

I find the solution, the problem was the mirror "http://mir.archlinux.fr/$repo/os/$arch", the firefox in this mirror is not the 17.0.1 version despite the name of the package, it was the 17.0 version,

so I set a new mirror : "http://mirror.archlinux.ikoula.com/arch … o/os/$arch", re-run "pacman -Syu" and all is Ok now, I have the real 17.0.1 version of pacman :

pacman -Q firefox :

firefox 17.0.1-1

Last edited by Potomac (2012-12-01 21:49:56)

Offline

#5 2012-12-01 22:24:57

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,343
Website

Re: [SOLVED] Firefox 17.0.1 not really updated

@OP - Use reflector for update and fast mirrors:

% which upp
upp: aliased to reflector -c "United States" -a 1 -f 10 --sort rate --save /etc/pacman.d/mirrorlist && cat /etc/pacman.d/mirrorlist && sudo pacman-color -Syyu

Note that you need to chown you:yourgroup /etc/pacman.d/mirrorlist for that alias to work but you get the idea.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB