You are not logged in.

#1 2012-12-03 18:20:03

lano1106
Member
From: Canada, Montreal
Registered: 2012-11-22
Posts: 81
Website

rootfs remains in ro at boot on fresh install with December ISO

Hi,

The first symptom that I have observed is that dhcpcd isn't able to update /etc/resolv.conf

I am going to provide as much relevant info so you can tell me what to look for

1. Installed from december iso on newly created GPT ext4 partitions
2. Bootloader GRUB2 x86_64
3. Did a systemctl mask tmpfs as I am mounting a disk partition on /tmp from fstab
4. Double checked 2-3 times that all my mounts are rw in fstab
5. Once logged, I have no problem doing "mount -o remount,rw /"
6. I have removed the ro kernel parameter option in grub.cfg (BTW, why is this used at all? I'm a little bit ignorant about Linux booting good practices). By doing so rootfs still remains ro.

I am suspecting either systemd or the content of the initramfs. Until now, those are still black boxes to me. What should I look at to resolve my rootfs ro problem?

thank you very much!
Olivier
(A new Arch user and extremely happy to have found and tried your distribution!)

Last edited by lano1106 (2012-12-03 18:21:16)

Offline

#2 2012-12-03 18:29:13

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: rootfs remains in ro at boot on fresh install with December ISO

Maybe you forgot to create /etc/fstab? See install guide wiki page and genfstab.

Offline

#3 2012-12-03 18:35:05

lano1106
Member
From: Canada, Montreal
Registered: 2012-11-22
Posts: 81
Website

Re: rootfs remains in ro at boot on fresh install with December ISO

I'm not totally ruling out that there is a problem with my fstab but I haven't forgetten that step.

Would the command 'mount -a' eliminate that potential cause?

See point #4 in the initial post.

I have about 7 entries in my fstab

/
/boot
/var
/home
/tmp
swap
networked CIFS drive

/dev/sda1 being the 2MB bios_grub partition required for GPT boot from BIOS.

The weird thing is that all partitions are ext4 with the same basic options generated by genfstab: rw,relatime

and only / is ro at boot.

Last edited by lano1106 (2012-12-03 18:43:16)

Offline

#4 2012-12-04 00:12:30

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: rootfs remains in ro at boot on fresh install with December ISO

Post fstab.

/tmp is no longer needed.

Maybe there is a fs error on /.  Usually / takes the option errors=remount-ro in fstab so this will happen if a problem is found.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2012-12-04 05:34:29

lano1106
Member
From: Canada, Montreal
Registered: 2012-11-22
Posts: 81
Website

Re: rootfs remains in ro at boot on fresh install with December ISO

Hi,

I have finally found my problem.  I have messes around with systemd and eventually, I wasn't able to get to the login prompt. At that point, I have decided to redo the installation from scratch.

My goal on the second attempt was to get something up and running fast hence, I have left to later all the small tweaking that I have set up on my first attempt.

One of the thing is that I wanted is to have a disk partition mounted on /tmp rather than having a tmpfs mount so I followed the recommendation in the Beginners guide that says to do:

systemctl mask tmp.mount

as soon as you do that and reboot it has the side effect that systemd do not remount the rootfs with the options specified in /etc/fstab (in my case rw)

to fix the problem, I just did

systemctl unmask tmp.mount

It seems that just specifying another partition for /tmp, it is enough for systemd to not use tmpfs.

Offline

#6 2012-12-04 10:33:38

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: rootfs remains in ro at boot on fresh install with December ISO

On a modern setup with initramfs and the 'fsck' enabled in the default mkinitcpio.conf, you can simply use 'rw' on the kernel command line. Bonus: Faster boot time with 'systemctl mask systemd-remount-fs.service'.

Offline

Board footer

Powered by FluxBB