You are not logged in.

#1 2012-12-03 18:24:52

Registered: 2012-12-02
Posts: 3

[SOLVED] iMac Blackscreen / Xorg no screens found

Hello ladies and gentlemen,

this is my first post so far. I am very satisfied with my archlinux setup on my macbook (2006). But i ran into a Problem i could not solve with google, arch forum and arch wiki.

===  The Setup ===
iMac from late 2010 (Computer with built-in Monitor)
Archlinux install from nov. 2012

=== The story  ===
I tried a lot of Linux distributions to install:
- Archlinux (from CD, Install-Image from 11/2012 )
- Ubuntu (from USB, v. 12.10 & 12.04 LTS)
- Cinnarch (12.11.22 minimal netinstaller)

I always ran into the same problem:
Booting w/ a black screen (no LED Backlight - It was possible to login and reboot the computer blindly)
booting w/ screen with nomodeset

I tried the Opensource ATI driver (i used the walkthrough on the WIKI)
and i also tried the closed-source catalyst-234k driver with old xorg-server (1.12 and 1.11).

=== The Issue ===
Normal Boot:
After ~1s of STDoutput i get a black screen without LED backlight (its like unplugging the Monitor) - I was able to login and reboot blindly

Fallback Boot (with Kernelmode "nomodeset" and "debug")
I can boot with no problems - but im not able to launch an xorg-server successfully.

I have no possibility to "startx" or "Xorg -configure" - it always throws me an error (No screens found)

===  The Logs / System Information ===

lsmod | grep radeon

radeon                  859655    0
ttm                       ...            1  radeon
drm_kms_player    ...            1 radeon
drm                       ...            3 ttm,drm_kms,radeon
i2c_algo_bit           ...            1 ....
i2c_core                 ...           6 ...

lspci | grep VGA

01:00.0  VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV730 XT [Mobility Radeon HD 4670]

cat /var/log/Xorg.0.log | grep EE

(EE) failed to load module VESA (module does not exist)
(EE) No drivers available

the xf86-video-ati is installed!
and if i install vesa drivers:
the screen freezes on startx and i have to hard-reboot.
I cant list whole log here, because i need to retype everything x(
...only informational stuff, some warnings and no errors:

(WW) the directory (/usr/share/fonts(OTF/) does not exist. 
(WW) open ACPI failed (/var/run/acpid.socked)(no such file or directory)

and on Xorg -configure

Number of created screens does not match number of detected devices.
Configuration failed.
Server terminated with error 2. closing logfile

my /root/.xinitrc and ~/.xinitrc

exec gnome-session

(yes, gnome is installed!)

thats it so far. any help?

=== The Solution  ===
- none yet.

Last edited by moolen (2012-12-07 09:50:27)


#2 2012-12-05 10:14:51

Registered: 2012-12-02
Posts: 3

Re: [SOLVED] iMac Blackscreen / Xorg no screens found

After re-installation the same issue. BUT:
when i boot from CD and arch-chroot in HD-system i can see the terminals when i startx.


#3 2012-12-07 09:49:43

Registered: 2012-12-02
Posts: 3

Re: [SOLVED] iMac Blackscreen / Xorg no screens found

I worked it out.

i used the awesome AUI script by helmuthdu

i installed X, loginmanager and a Desktop environment and it works well.


Board footer

Powered by FluxBB