You are not logged in.

#1 2012-12-04 21:13:36

oniichan
Member
Registered: 2012-08-08
Posts: 31

Disgustingly slow boot from SSD

Everything plugged in:
http://sprunge.us/jaDN
Mouse plugged out, keyboards in:
http://sprunge.us/OFhd
No USB units:
http://sprunge.us/UeeF

As you can see, my boot time is disgustingly slow. Kernel takes 63013ms according to systemd-analyze, and userspace takes 7013. From the logs I can clearly see that there's something wrong with some USB unit, the question is how do I get my kernel to boot faster? I know this isn't normal, my slow sloppy USB install boots faster, and so did my mechanical HDD install on another machine.

Might aswell throw some specs in here since it might be a chipset problem. The motherboard is a Asus IV formula, 890SB chipset I believe. The disk is a Corsair Force3 (latest firmware) and it's running on the sata3 6gbps port.

Last edited by oniichan (2012-12-04 21:17:00)

Offline

#2 2012-12-04 21:26:31

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,754

Re: Disgustingly slow boot from SSD

There's stuff like

[   67.651015] ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[   67.651228] ata4.00: failed command: IDENTIFY PACKET DEVICE
[   67.651394] ata4.00: cmd a1/00:01:00:00:00/00:00:00:00:00/00 tag 0 pio 512 in
         res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[   67.651817] ata4.00: status: { DRDY }
[   67.651927] ata4: hard resetting link
[   68.137527] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[   68.939722] ata4.00: configured for PIO4
[   69.740195] ata4: EH complete

in all those logs, and apparenttly ata4 is your optical drive:

[    1.346501] ata4.00: ATAPI: TSSTcorp CDDVDW SH-S223C, SB05, max MWDMA2

But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#3 2012-12-04 21:33:41

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 681

Re: Disgustingly slow boot from SSD

Honestly - I had this after fitting an SSD. SATA connections are not as robust physically as older IDE connections, and as such can drift to the point of "just connected" very easily.

Get back inside the computer and make sure that ALL your drive connectors (both to the drives and the ports) are solid and straight. You'd be surprised how easily they can throw those errors if they are just a little out.


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Nvidia GTX 670 2Gb, AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked) 8GB RAM
Linux user #545703

Offline

#4 2012-12-04 21:52:40

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,647
Website

Re: Disgustingly slow boot from SSD

Hmm... how does this disk compare to those with published benchmarks?

https://wiki.archlinux.org/index.php/SSD_Benchmarking


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#5 2012-12-08 12:14:02

oniichan
Member
Registered: 2012-08-08
Posts: 31

Re: Disgustingly slow boot from SSD

I plugged the Optical bay out, and boot times are now significantly faster. No loose SATA cables or anything.
I don't want a system where I'm forced to have my optical bay plugged out, i actually use it.
Any solutions?

Offline

#6 2012-12-08 19:19:25

ANOKNUSA
Member
Registered: 2010-10-22
Posts: 2,141

Re: Disgustingly slow boot from SSD

You could maybe blacklist the optical drive's module in /etc/modprobe.d, and call the module when necessary--or, as a slightly more extreme alternative, switch off power to it in BIOS unless you need to use it if you have that capability (would still require a reboot every time you need it, so it's only slightly less tedious than opening the case and unplugging it hmm).

Offline

#7 2012-12-08 19:56:47

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Disgustingly slow boot from SSD

Have you tried looking at the boot device options and order in the BIOS? You may be able to remove the option to boot from the optical drive, or at lease move it down to the bottom of the list.


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#8 2012-12-08 21:52:22

azleifel
Member
Registered: 2007-10-28
Posts: 476

Re: Disgustingly slow boot from SSD

I've got one of those Samsung SH-223C drives and they are a pain because they don't like the 16-byte pass-through commands that udev uses (search your logs for "IDENTIFY PACKET DEVICE" errors).  The fix has been posted here several times: Add

options libata atapi_passthru16=0 force=5:udma5

to /etc/modprobe.d/modprobe.conf, add

FILES="/etc/modprobe.d/modprobe.conf"

to /etc/mkinitcpio.conf, rebuild the kernel image with mkinitcpio and reboot.

Offline

#9 2012-12-09 12:21:09

oniichan
Member
Registered: 2012-08-08
Posts: 31

Re: Disgustingly slow boot from SSD

Yep, it works now. Thank you.

Offline

Board footer

Powered by FluxBB