You are not logged in.

#1 2012-12-07 04:22:03

Registered: 2008-01-23
Posts: 58

Weird colour shift on TV through HDMI


I'm using my TV with XBMC to watch videos on my computer more comfortably, but even since I changed my computer the image get those weird shifts where it goes black for about a second, comes back on looking weird, then about 20 seconds later it's one second of black and then back on as normal again. But if I change channel on my TV when it happens, and then switch back to the HDMI channel corresponding to my computer, the image is fixed. I've tried timing this issue, and it seems to appear roughly every 20 minutes, but it can appear twice in 5 minutes, or not at all in 40...

Because an image is worth a hundred words, I took a picture with my phone during one of these colour shifts, here's what it looks like: . As you can see by the xbmc menu looking weird too, this is not the video's fault.

I've also tried switching the cable, but the issue remains. I've been using this setup for a while, but as I said, I changed computer recently, and part of this change was going from a nVidia card to an ATI one, more specifically a radeon HD 7870, and I'm using the official AMD driver (which is kind of required, since the free driver apparently doesn't support sound over HDMI for my card yet).

It's probably worth mentioning that my primary display, which is plugged in VGA, does not have this issue. Also, I have a Windows dual-boot, but I have yet to test if this issue also appears on Windows (which is kind of a pain to do, due to the randomness of my issue...).

I've tried googling this for days and have yet to find anyone reporting the same issue, but seeing how English isn't my native language, I might not have used the right keywords...

Because I guess this is relevant, here is my xorg.conf on pastebin: . This was generated using amdcccle, so it should be legit (though I do miss nvidia-settings, amd got some work to do on their GUI tool). Not sure if this is relevant, but just in case : to launch the computer on my TV, I use this xorg.conf (named xorg.conf.TV in my system), and start X with the following command (through an alias, of course):

xinit .xinitrcTV -- /usr/bin/X :1 -config xorg.conf.TV

And my .xinitrcTV containing the following:

setxkbmap fr

So here I am, and I don't really have any idea what I could do to fix this problem... Any help would be greatly appreciated.


Board footer

Powered by FluxBB