You are not logged in.

#1 2012-12-08 18:30:33

phects
Member
Registered: 2010-08-31
Posts: 10

udev rules for power saving do not work

Hey,

I need some help regarding the power saving tunings recommended by the "Power saving" wiki page. The udev rules I added are as follows:

# for i in /etc/udev/rules.d/*; do echo $i:; cat $i; echo; done
/etc/udev/rules.d/disable-wol.rules:
ACTION=="add", SUBSYSTEM=="net", KERNEL=="eth*" RUN+="/usr/sbin/ethtool -s %k wol d"

/etc/udev/rules.d/pci-pm.rules:
ACTION=="add", SUBSYSTEM=="pci", ATTR{power/control}="auto"

/etc/udev/rules.d/sata-powersaving.rules:
SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="min_power"

/etc/udev/rules.d/usb-autosuspend.rules:
ACTION=="add", SUBSYSTEM=="usb", TEST=="power/control" ATTR{power/control}="auto"
ACTION=="add", SUBSYSTEM=="usb", TEST=="power/autosuspend" ATTR{power/autosuspend}="2"

/etc/udev/rules.d/wifi-powersaving.rules:
ACTION=="add", SUBSYSTEM=="net", KERNEL=="wlan*" RUN+="/usr/sbin/iw dev %k set power_save on"

udev indicates no error. However, the settings do not seem to be applied properly.

This is, what powertop thinks ("Schlecht" is german for "Bad"):

Schlecht      Wireless Power Saving for interface wlan0                                                              
Schlecht      Enable SATA link power management for /dev/sda                                                         
Schlecht      VM writeback timeout
Schlecht      Enable Audio codec power management
Schlecht      Autosuspend for unknown USB device 4-1 (8087:0024)
Schlecht      Autosuspend for USB device EHCI Host Controller [usb3]
# cat /sys/devices/pci0000:00/0000:00:1f.2/ata?/host?/scsi_host/host?/link_power_management_policy
max_performance
max_performance
max_performance
max_performance
max_performance
max_performance

Is it possible that the settings get overridden somehow? Is there a way to debug, if the udev rules actually cause writing to /sys or something like that?

Thanks in advance!
henning

Offline

#2 2012-12-08 22:25:35

Tarqi
Member
From: Ixtlan
Registered: 2012-11-27
Posts: 106
Website

Re: udev rules for power saving do not work

Did you reboot?


Knowing others is wisdom, knowing yourself is enlightenment. ~Lao Tse

Offline

#3 2012-12-08 22:34:29

phects
Member
Registered: 2010-08-31
Posts: 10

Re: udev rules for power saving do not work

Yes.

Offline

#4 2012-12-08 22:54:56

Tarqi
Member
From: Ixtlan
Registered: 2012-11-27
Posts: 106
Website

Re: udev rules for power saving do not work

Hm, did nearly the same here (no DE), and it seems to work.

phects wrote:

Is there a way to debug, if the udev rules actually cause writing to /sys or something like that?

Simply check the attributes you specified in you udev-rules in /sys, first with the rules disabled, then enabled. This will show you if something changes in there.


Knowing others is wisdom, knowing yourself is enlightenment. ~Lao Tse

Offline

Board footer

Powered by FluxBB