You are not logged in.

#1 2012-12-08 20:43:04

From: Texas
Registered: 2012-12-08
Posts: 2

[Solved] Mesa-full-i965 won't build

I solved the build error by editing the PKGBUILD from

--with-gallium-drivers= \


--with-gallium-drivers=swrast \


I've installed the Steam beta and it updates okay (I have to unset the immutable flag for /usr/bin/steam), but when I run it, it fails to load the i965 driver. Steam's error looks the same as in this thread. After searching the AUR for i965, the only packages are mesa-full-i965 and the lib32 version.

I tried installing mesa-full-i965 and everything compiled fine until this error:

make[4]: *** No rule to make target `../../src/mesa/program/', needed by `'.  Stop.
make[4]: Leaving directory `/home/luke/Build/lib32-mesa-full-i965/src/mesa-build/src/mesa'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/luke/Build/lib32-mesa-full-i965/src/mesa-build/src/mesa'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/luke/Build/lib32-mesa-full-i965/src/mesa-build/src/mesa'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/luke/Build/lib32-mesa-full-i965/src/mesa-build/src'
make: *** [all-recursive] Error 1
==> ERROR: A failure occurred in build().

I've tried searching around, but there doesn't seem to be anything relevant. The full makepkg output is here. Let me know if you need any more information.

I thought I was running i686, but I'm not. I tried installing both the lib32 and regular version with the same results.

Last edited by piluke (2012-12-09 04:20:13)


Board footer

Powered by FluxBB