You are not logged in.

#1 2012-12-09 13:38:52

niharsarangi
Member
From: Madison, WI
Registered: 2012-08-26
Posts: 29
Website

systemd breaks after the update

After the recent update, the

systemd

service fails to start. syslog socket is not able to load.

kdm fails to load, and I am asked to login to console.

Any ideas on how to fix this?

Offline

#2 2012-12-10 19:42:17

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,060
Website

Re: systemd breaks after the update

niharsarangi wrote:

I am asked to login to console.

Are you able to login on the console and get a working command line?

Offline

#3 2012-12-10 19:44:03

niharsarangi
Member
From: Madison, WI
Registered: 2012-08-26
Posts: 29
Website

Re: systemd breaks after the update

Yes. console login works just fine.
But if I startx from console it says modprobe can't locate 'nvidia' and X fails to launch.

Offline

#4 2012-12-10 19:57:50

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,060
Website

Re: systemd breaks after the update

To check if 'nvidia' is really missing look here:
usr/lib/modules/extramodules-3.6-ARCH/nvidia.ko.gz

Offline

#5 2012-12-10 20:11:23

niharsarangi
Member
From: Madison, WI
Registered: 2012-08-26
Posts: 29
Website

Re: systemd breaks after the update

No, nvidia.ko.gz is present. sad

Offline

#6 2012-12-10 21:17:47

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,060
Website

Re: systemd breaks after the update

Look up which packages have been upgraded in /var/log/pacman.log .

Last edited by teateawhy (2012-12-10 21:18:15)

Offline

Board footer

Powered by FluxBB