You are not logged in.

#1 2012-12-10 08:10:48

HatBoy
Member
Registered: 2012-12-10
Posts: 3

After a couple recent updates, No Headphone Output.

Hey, I've searched all over and still can't find a working solution.  I have an "Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller".  After a couple recent updates I've lost sound output through my audio jack/with headphones.  I'm using kernel 3.6.9-1-ARCH with systemd, ALSA, and PulseAudio.  Not really sure which outputs to paste here to help.  All answers would be really appreciated, thanks!

Offline

#2 2012-12-10 14:40:09

xpixelz
Member
From: Tunisia
Registered: 2012-02-29
Posts: 47
Website

Re: After a couple recent updates, No Headphone Output.

It would be easier for you first to find out with a GUI app like pavucontrol or aumix from command line (ncurses interface).

Offline

#3 2012-12-11 00:18:57

caltac
Member
Registered: 2012-11-27
Posts: 22

Re: After a couple recent updates, No Headphone Output.

Have you checked to make sure no channels are muted in alsamixer?

Offline

#4 2012-12-27 03:46:49

HatBoy
Member
Registered: 2012-12-10
Posts: 3

Re: After a couple recent updates, No Headphone Output.

Ok, I installed pavucontrol, and switched my output to speakers.  It would seem that when it is set to headphones (auto-volume switching), it is attempting to send audio to a non-existent channel on the sound card.  I believe the switching of audio is all done through the card, which is why it breaks when it is done through software (it works through headphones when speakers are set as output).  Would there be a way to change the output for "Headphones" to the speaker channel, so that automatic volume saving for headphone output and speaker output still work, without breaking audio output?

Last edited by HatBoy (2012-12-27 03:47:06)

Offline

#5 2013-01-04 06:26:30

HatBoy
Member
Registered: 2012-12-10
Posts: 3

Re: After a couple recent updates, No Headphone Output.

Bump?

Offline

#6 2013-01-04 08:16:42

sirmacik
Member
From: Poland/Warsaw
Registered: 2008-06-17
Posts: 63
Website

Re: After a couple recent updates, No Headphone Output.

Hi!

I don't know if this will solve your problem but it seems that adding this file (/etc/modprobe.d/sound.conf) worked for me:

options snd-hda-intel model=auto

Then reboot.

It appeared that above solution isn't the right one so I've written this short script that finally works for me:

#!/bin/sh

# OK so this even exists because after suspending my Dell Vostro 3350 
# without headphones plugged in they won't work after resuming from it. 
# Same goes for speakers at suspend with headphones plugged. 
#
# So how this script works?
# - Stop any player that might be using sound output right.
# - Plug or unplug your headphones depending on what output you want to get 
#   working and run this script.
#
# *Must be run as root*

BATSTAT="`cat /sys/class/power_supply/AC/online`"

if test $BATSTAT -gt 0  
then  
    echo "1" | tee "/sys/module/snd_hda_intel/parameters/power_save" &>/dev/null 
    echo "Y" | tee "/sys/module/snd_hda_intel/parameters/power_save_controller" &>/dev/null 
    echo "1" | tee "/sys/module/snd_ac97_codec/parameters/power_save" &>/dev/null


    echo "0" | tee "/sys/module/snd_hda_intel/parameters/power_save" &>/dev/null  
    echo "N" | tee "/sys/module/snd_hda_intel/parameters/power_save_controller" &>/dev/null 
    echo "0" | tee "/sys/module/snd_ac97_codec/parameters/power_save" &>/dev/null

else 
    echo "0" | tee "/sys/module/snd_hda_intel/parameters/power_save" &>/dev/null  
    echo "N" | tee "/sys/module/snd_hda_intel/parameters/power_save_controller" &>/dev/null 
    echo "0" | tee "/sys/module/snd_ac97_codec/parameters/power_save" &>/dev/null

    echo "1" | tee "/sys/module/snd_hda_intel/parameters/power_save" &>/dev/null                
    echo "Y" | tee "/sys/module/snd_hda_intel/parameters/power_save_controller" &>/dev/null
    echo "1" | tee "/sys/module/snd_ac97_codec/parameters/power_save" &>/dev/null
fi

Last edited by sirmacik (2013-01-06 09:57:03)

Offline

Board footer

Powered by FluxBB