You are not logged in.

#1 2012-12-11 18:50:23

kurt
Member
Registered: 2009-09-06
Posts: 91

mplayer & gnome screenplayer

I'm using mplayer without a GUI on gnome 3.6. When I'm watching a vid the screensaver comes on. Is there a way to stop this happening.

I've tried the ~/.mplayer/config lines as suggested by the wiki:

stop-xscreensaver="yes" # stop gnome-screensaver

But it still comes on.

Any help would be much appreciated

Offline

#2 2012-12-11 19:07:30

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: mplayer & gnome screenplayer

You may want to use

hearbeat-cmd="gnome-screensaver"

with a correct parameter if needed. AFAIK, it's all about some limitation in gnome-screesaver's behaviour. See both mplayer's manual and relevant examples over the net.

Last edited by bohoomil (2012-12-11 19:08:31)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#3 2012-12-12 14:44:49

kurt
Member
Registered: 2009-09-06
Posts: 91

Re: mplayer & gnome screenplayer

bohoomil wrote:

You may want to use

hearbeat-cmd="gnome-screensaver"

with a correct parameter if needed. AFAIK, it's all about some limitation in gnome-screesaver's behaviour. See both mplayer's manual and relevant examples over the net.

I did a quick search before I posted and had tried the following two options. Neither worked

1) heartbeat-cmd="gnome-screensaver-command -p" # This option no longer seems to be available so tried
2) heartbeat-cmd="gnome-screensaver-command -d"

In response to your reply I tried it without the "-command". Still no joy.

VLC works fine but I would like to use mplayer. I will carry on searching but thanks for your help.

Offline

#4 2012-12-12 16:21:49

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: mplayer & gnome screenplayer

If you don't mind installing a program, you could use caffeine-bzr from the AUR to disable the screensaver.

Offline

Board footer

Powered by FluxBB