You are not logged in.

#1 2012-12-12 09:03:41

Registered: 2010-06-20
Posts: 15

[Solved] Newznab not working

Has anyone out there tried using Newznab on Arch? I installed it according to several different guides, changing various things
as necessary for Arch. Of course, I installed LAMP first and followed the wiki to get that up.

Everything seems to work well upon starting Newznab, and I can go through the setup screens no problem. However, once I get to the main page, every single
link I click on gets me a 404, aside from the one going to the Admin screen. It works fine under a VM running Ubuntu.

Error log gets me entries like this:

[Wed Dec 12 01:52:27 2012] [error] [client ::1] File does not exist: /srv/http/newznab/www/login, referer:

Of course, there's no actual "login" file, but rather it's supposed to run a php script.

So I'm guessing (I dunno) it's a PHP configuration issue of some kind. I've been pulling my hair out trying to figure it out, trying to figure out what is different from the
ubuntu installation and this one, and why it works and this one doesn't. I'm at a loss.

Last edited by Zamboniman (2012-12-13 01:07:58)


#2 2012-12-13 01:10:40

Registered: 2010-06-20
Posts: 15

Re: [Solved] Newznab not working

Well, that was a frustrating experience. I've been pulling my hair out for two days, on and off, trying to get this to work.

I finally figured it out. Notwithstanding my lack of experience and understanding of PHP and Apache.

I had to create a specific directory entry for where newznab/www resides in /etc/httpd/conf/httpd.conf and ensure

AllowOverride all

was set within the directory entry. Then, restart httpd and boom: it works.


Board footer

Powered by FluxBB