You are not logged in.

#1 2012-12-15 15:17:46

Registered: 2012-12-15
Posts: 3

[SOLVED] Gnome3 Nautilus (3.6) - Delete Key

i've installed Gnome3 and encountered that I can't delete Files in Nautilus with the delete key (I have to use ctrl-del). I checked a few forums and found a solution:

Quick fix:
Run dconf-editor, and open:
org -> gnome -> desktop -> interface
Enable "can-change-accels".
Open nautilus, select any file/directory, then click "Edit" from menubar, and hover on "Move to Trash" menuitem.
While hovering, click on your delete key. The accel should change from "cntrl+del" to "del".
Make sure you have selected a file, else the "Move to Trash" menuitem will be greyed out.

My problem right now is, that there's no menubar in my version of nautilus (also I can't find any preferences in dconf to enable it - org.gnome.nautilus.window-state start-with-toolbar true don't work).
Is there a config file where i can specify my keybindings for Nautilus or any other solution for this problem?

Thank you,

Edit SOLVED: edit ~/.config/nautilus/accels, search line:
; (gtk_accel_path "<Actions>/DirViewActions/Trash" "<Primary>Delete")
uncomment and change to the command you want to use. e.g.
(gtk_accel_path "<Actions>/DirViewActions/Trash" "Delete")

Last edited by Kagu (2012-12-19 23:41:12)


Board footer

Powered by FluxBB