You are not logged in.

#1 2012-12-16 08:40:05

89c51
Member
Registered: 2012-06-05
Posts: 659

[Solved]Latest ntp.

When you run something like

ntpq -c peers
ntpq: error while loading shared libraries: libedit.so.0: cannot open shared object file: No such file or directory

Installing libedit fixes it of course but shouldn't it be a dependency on this???

Last edited by 89c51 (2012-12-19 14:53:59)

Offline

#2 2012-12-16 22:50:55

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,537

Re: [Solved]Latest ntp.

I think you're right. libedit isn't in base, so this dependency should be declared. Open a bug report.

Offline

#3 2012-12-16 22:54:44

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,096
Website

Re: [Solved]Latest ntp.

No, this package shouldn't depend on libedit at all. It wasn't built properly. Regardless, bug report.

Offline

#4 2012-12-19 14:53:47

89c51
Member
Registered: 2012-06-05
Posts: 659

Re: [Solved]Latest ntp.

The maintainer added libedid as an optional dependency so marking this solved.

Offline

#5 2012-12-20 13:38:43

oldpond
Member
Registered: 2010-01-26
Posts: 41

Re: [Solved]Latest ntp.

Making it optional did not solve the problem.

(1/2) installing ntp                                                                                                                           [#######################################################################################] 100%
Optional dependencies for ntp
    libedit: ntpdc, ntpq
root /home/glide # systemctl enable ntpd.service
root /home/glide # systemctl start ntpd
root /home/glide # ntpq
ntpq: error while loading shared libraries: libedit.so.0: cannot open shared object file: No such file or directory
root /home/glide #


oldpond = glide

Offline

#6 2012-12-20 14:17:28

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,537

Re: [Solved]Latest ntp.

The optdepend says that if you want to use ntpq and ntpdc, you need libedit. If you just want to run ntpd, you don't need it.

Offline

#7 2013-02-17 19:43:06

andreas_baumann
Member
Registered: 2011-05-04
Posts: 14

Re: [Solved]Latest ntp.

This is wrong IMHO: it's fine for the ntp package not to depend on libedit and have a optdepend.
But bundling broken binaries like ntpq and ntpdc is not an option, they should not be part of the 'ntp'
package in this case!

What about splitting the package in 'ntp-server' and 'ntp-client', server having no libedit, client having
libedit as dependency?

Offline

Board footer

Powered by FluxBB