You are not logged in.

#1 2012-12-16 18:55:45

edmael
Member
From: Corte de' Frati, Italy
Registered: 2012-07-19
Posts: 54
Website

Compilation problem with lib32-wxgtk

Hi,
when I try to compile lib32-wxgtk I get this error:

checking for GTK+ - version >= 2.0.0... 
*** 'pkg-config --modversion gtk+-2.0' returned 2.24.14, but GTK+ (2.24.13)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

Both gtk and lib32-gtk meta-packages are installed, I just don't understand what's wrong.
Any suggestion on how to continue?

Thanks.

Offline

#2 2012-12-16 21:27:06

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,134

Re: Compilation problem with lib32-wxgtk

edmael wrote:

Problem solved, just a pacman -Syu needed.
I forget to check if everything was up to date before posting, sorry.

I think you meant to use the 'reply' link, not the 'report' link.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB