You are not logged in.

#1 2012-12-20 19:58:56

jgreen1tc
Member
From: St. Louis
Registered: 2011-05-16
Posts: 247

net-auto-wireless wont connect to my profiles

net-auto-wireless used to work fine for me but I have had to manually connecting to my networks for a long time now. net-auto-wired works just fine, and I have followed the wiki to the letter. Where can I begin to look in order to find what is causing this problem?

Offline

#2 2012-12-21 03:56:08

Hspasta
Member
Registered: 2011-12-24
Posts: 187
Website

Re: net-auto-wireless wont connect to my profiles

you created your wireless profiles with 'wireless-wpa-configsection' right? Are your profiles listed in /etc/conf.d/netcfg under AUTO_PROFILES?

Do you have wpa_actiond installed?

Offline

#3 2012-12-21 04:32:18

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: net-auto-wireless wont connect to my profiles

Your question is a bit sparse on the details.

Offline

#4 2012-12-21 04:56:30

jgreen1tc
Member
From: St. Louis
Registered: 2011-05-16
Posts: 247

Re: net-auto-wireless wont connect to my profiles

Hspasta wrote:

you created your wireless profiles with 'wireless-wpa-configsection' right? Are your profiles listed in /etc/conf.d/netcfg under AUTO_PROFILES?

Do you have wpa_actiond installed?

The wiki states that the profiles may be 'wireless-wpa' which they are (either that or by using wifi-menu). I will see if re-creating them changes anything on the ones made this way. The wiki and conf file also state that when not specified, all wireless profiles are considered which doesn't seem to work in my case. I occasionally have to bring up the interface with ifconfig, but usually not.

Sorry for the lack of info. I don't know enough to know what I should include to make helping me easier.

Thank you for reading and replying.

Edit:

pm -Ss wpa_actiond
core/wpa_actiond 1.3-1 [installed]
    Daemon that connects to wpa_supplicant and handles connect and disconnect events

One of my profiles:

CONNECTION='wireless'
DESCRIPTION='A simple WPA encrypted wireless connection'
INTERFACE='wlan0'
SECURITY='wpa'
ESSID='TinyMonkey'
KEY='********'
IP='dhcp' 
#POST_UP=
#PRE_DOWN=
# Uncomment this if your ssid is hidden
#HIDDEN=yes

Last edited by jgreen1tc (2012-12-21 05:02:21)

Offline

#5 2012-12-21 09:33:17

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,838

Re: net-auto-wireless wont connect to my profiles

When you say you manually connect do you mean like this?

# netcfg <profile>

If so, then can you post the /etc/conf.d/netcfg file, and the /etc/systemd/system/net-auto-wireless.service file? Just to rule out the obvious, really.
If not, then can you try connecting like that? See what you get back (setting the env variable NETCFG_DEBUG to 1 helps as well).


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#6 2012-12-21 20:08:22

jgreen1tc
Member
From: St. Louis
Registered: 2011-05-16
Posts: 247

Re: net-auto-wireless wont connect to my profiles

skanky wrote:

When you say you manually connect do you mean like this?

# netcfg <profile>

If so, then can you post the /etc/conf.d/netcfg file, and the /etc/systemd/system/net-auto-wireless.service file? Just to rule out the obvious, really.
If not, then can you try connecting like that? See what you get back (setting the env variable NETCFG_DEBUG to 1 helps as well).

Yes, that is the way I have to manually connect each time. Sometimes I have to do

# ifconfig wlan0 up

before I can run it, but usually not.

As for the files:

cat /etc/conf.d/netcfg
# Enable these netcfg profiles at boot time.
#   - prefix an entry with a '@' to background its startup
#   - set to 'last' to restore the profiles running at the last shutdown
#   - set to 'menu' to present a menu (requires the dialog package)
# Network profiles are found in /etc/network.d
NETWORKS=(last)

# Specify the name of your wired interface for net-auto-wired
WIRED_INTERFACE="eth0"

# Specify the name of your wireless interface for net-auto-wireless
WIRELESS_INTERFACE="wlan0"

# Array of profiles that may be started by net-auto-wireless.
# When not specified, all wireless profiles are considered.
#AUTO_PROFILES=("profile1" "profile2")
cat /etc/systemd/system/multi-user.target.wants/net-auto-wireless.service                                                                                                                   
[Unit]
Description=Provides automatic netcfg wireless connection
Before=network.target
Wants=network.target

[Service]
EnvironmentFile=/etc/conf.d/netcfg
ExecStart=/usr/bin/netcfg-wpa_actiond $WIRELESS_INTERFACE
ExecStop=/usr/bin/netcfg-wpa_actiond stop $WIRELESS_INTERFACE
RemainAfterExit=yes
Type=forking

[Install]
WantedBy=multi-user.target

Last edited by jgreen1tc (2012-12-21 20:09:33)

Offline

#7 2012-12-21 20:57:20

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,838

Re: net-auto-wireless wont connect to my profiles

Thanks. Does it work if you put any/all profile in the NETWORKS entry in conf.d/netcfg?
I've got two of mine listed in there - my wired one and my usual wireless one.

EDIT: I'm assuming you did the steps specified in the wiki for 'last', but am just checking that the error isn't in there, somewhere.

Last edited by skanky (2012-12-21 21:00:07)


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#8 2012-12-21 21:27:35

jgreen1tc
Member
From: St. Louis
Registered: 2011-05-16
Posts: 247

Re: net-auto-wireless wont connect to my profiles

Yes. I have put all my networks in there at one point. Still no dice.

Offline

#9 2012-12-21 21:38:29

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,838

Re: net-auto-wireless wont connect to my profiles

Can you post the output of a manual connect with the NETCFG_DEBUG var set to 1 (as per https://wiki.archlinux.org/index.php/Ne … leshooting )?

When it fails, have you run:-

# systemctl status net-auto-wireless

?

Also, you could try searching the output of journalctl to for netcfg and net-auto-wirless to see if there's anything useful in there. It should record start-up failures. The above command gives the most recent entry (plus some other info) but, this would check whether there's more than one issue, maybe.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#10 2012-12-22 02:19:18

jgreen1tc
Member
From: St. Louis
Registered: 2011-05-16
Posts: 247

Re: net-auto-wireless wont connect to my profiles

Debug of netcfg turned up nothing as I was starting my profile manually. However:

sudo systemctl status net-auto-wireless
[sudo] password for jgreen1tc: 
net-auto-wireless.service - Provides automatic netcfg wireless connection
          Loaded: loaded (/usr/lib/systemd/system/net-auto-wireless.service; enabled)
          Active: failed (Result: exit-code) since Fri, 2012-12-21 20:00:16 CST; 4min 30s ago
         Process: 799 ExecStart=/usr/bin/netcfg-wpa_actiond $WIRELESS_INTERFACE (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/net-auto-wireless.service

Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: LindenwoodGuest
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: wlan0-Lindenwood
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: ethernet_dhcp
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: wlan0-CornerCoffee
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: TinyMonkey
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: Line 29: Invalid passphrase length 0 (expected: 8..63) '"'.
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: Line 29: failed to parse psk '""'.
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: Line 31: WPA-PSK accepted for key management, but no PSK configured.
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: Line 31: failed to parse network block.
Dec 21 20:00:17 HAL9000 netcfg-wpa_actiond[799]: Failed to read or parse configuration '/run/network/wpa.wlan0/wpa.conf'.

I am at a loss with these errors. Thank you for helping thus far.

Last edited by jgreen1tc (2012-12-22 02:19:54)

Offline

#11 2012-12-22 03:22:07

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: net-auto-wireless wont connect to my profiles

I think that netcfg actually handles putting the interface up and down now.  But you have to have rfkill installed.  At least I think this is true.

Offline

#12 2012-12-22 07:57:41

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,838

Re: net-auto-wireless wont connect to my profiles

Sorry on phone today so hard to help now - can't see all of the bit in code tags.

My recollection is that rfkill is or used to be needed. Can't check at the moment though. Sorry.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#13 2012-12-22 19:20:05

jgreen1tc
Member
From: St. Louis
Registered: 2011-05-16
Posts: 247

Re: net-auto-wireless wont connect to my profiles

I see. I have followed this wiki and have set up the following:

cat /etc/network.d/interfaces/wlan0
RFKILL=soft # can be either 'hard' or 'soft'
RFKILL_NAME='phy0'

Note, neither switch seems to be blocked (I don't even think I have a hardware switch):

rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

But it seems the netcfg fails for a different reason now:

systemctl status netcfg.service
netcfg.service - Netcfg multi-profile daemon
          Loaded: loaded (/usr/lib/systemd/system/netcfg.service; enabled)
          Active: failed (Result: exit-code) since Sat, 2012-12-22 12:47:06 CST; 24s ago
         Process: 722 ExecStart=/usr/bin/netcfg-daemon start (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/netcfg.service

However, I found another thread that has a similar issue. I am trying this solution but replacing the unit used in the example with the one I found by running systemctl --full

Edit: Unless I am missing something fundamental, which I probably am, the problem persists after trying the above.

Last edited by jgreen1tc (2012-12-22 21:06:49)

Offline

#14 2012-12-22 22:39:25

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,838

Re: net-auto-wireless wont connect to my profiles

Okay, two quick things:

1) Your first error looks like a mistake in the profile. If that profile works manually, I'm not sure. You could look at '/run/network/wpa.wlan0/wpa.conf' to see if there's an obvious mistake.

2) The second you need more info. Try searching the journald output for netcfg. See if there's another error. It's worth looking into the netcfg quirks and searching on your wireless card. It may be that you need slightly different quirks than in that thread for your card. I have never used netcfg quirks (fortunately for me) so can't really help with those.

Might want to post the card on here in case someone else has one.

Sorry I'm not much more use than that. I'm also going to be offline for a while, hope you get it sorted.


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#15 2013-02-03 12:26:52

MarSoft
Member
Registered: 2013-02-03
Posts: 5

Re: net-auto-wireless wont connect to my profiles

Hello,
I had the same problem. In my case, manual connecting with either wifi-menu or netcfg was working fine, while net-auto-wireless was failing with the following errors:

$ systemctl status net-auto-wireless
net-auto-wireless.service - Provides automatic netcfg wireless connection
          Loaded: loaded (/usr/lib/systemd/system/net-auto-wireless.service; enabled)
          Active: failed (Result: exit-code) since Вс 2013-02-03 10:58:56 MSK; 5h 6min ago
         Process: 340 ExecStart=/usr/bin/netcfg-wpa_actiond $WIRELESS_INTERFACE (code=exited, status=1/FAILURE)

feb 03 10:58:54 bookone netcfg-wpa_actiond[340]: wlan0-MarSoft
feb 03 10:58:55 bookone netcfg-wpa_actiond[340]: wlan0-
feb 03 10:58:55 bookone netcfg-wpa_actiond[340]: Line 17: Invalid passphrase length 0 (expected: 8..63) '"'.
feb 03 10:58:55 bookone netcfg-wpa_actiond[340]: Line 17: failed to parse psk '""'.
feb 03 10:58:55 bookone netcfg-wpa_actiond[340]: Line 19: WPA-PSK accepted for key management, but no PSK configured.
feb 03 10:58:55 bookone netcfg-wpa_actiond[340]: Line 19: failed to parse network block.
feb 03 10:58:55 bookone netcfg-wpa_actiond[340]: Failed to read or parse configuration '/run/network/wpa.wlan0/wpa.conf'.
feb 03 10:58:56 bookone systemd[1]: net-auto-wireless.service: control process exited, code=exited status=1
feb 03 10:58:56 bookone systemd[1]: Failed to start Provides automatic netcfg wireless connection.
feb 03 10:58:56 bookone systemd[1]: Unit net-auto-wireless.service entered failed state

Here is my network profile, as it was generated by wifi-menu:

$ cat /etc/network.d/wlan0-MarSoft 
CONNECTION='wireless'
DESCRIPTION='Automatically generated profile by wifi-menu'
INTERFACE='wlan0'
SECURITY='wpa'
ESSID=MarSoft
IP='dhcp'
KEY=Secret\ Code

Note the absense of quotes in ESSID and KEY lines.
After adding these quotes (and removing unneeded now backslash in KEY line) everything works fine.
So it seems that netcfg-wpa_actiond doesn't support such form of profile files, while wifi-menu does and actively uses it. It seems to be a bug for me.

Offline

Board footer

Powered by FluxBB