You are not logged in.

#1 2012-12-22 22:23:44

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,060
Website

Warning message while upgrading libreoffice-common

Hello,

while upgrading libreoffice-common to version libreoffice-common-3.6.4-3 the following line appeared in pacman's output:
( 4/15) Aktualisiere libreoffice-common       100%
/tmp/alpm_2NDWMR/.INSTALL: Zeile 27: xdg-icon-resource: Kommando nicht gefunden. ( Command not found. )
Is it a bug?

Last edited by teateawhy (2012-12-22 22:24:06)

Offline

#2 2012-12-22 22:58:32

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,193
Website

Re: Warning message while upgrading libreoffice-common

teateawhy wrote:

Is it a bug?

xdg-icon-resource belongs to extra/xdg-utils which is a dependency of libreoffice-common.  Do you have xdg-utils installed?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2012-12-23 12:46:18

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,060
Website

Re: Warning message while upgrading libreoffice-common

Thanks, now i see what happened. Xdg-utils is not installed, because it was replaced by the 'mimi' package. (created by taylorchu https://bbs.archlinux.org/viewtopic.php?id=135146 )

provides=('xdg-utils')
conflicts=('xdg-utils')

Provides is not really true, because the xdg-icon-resource is not part of the mimi package. Do you think i should forward this to taylorchu?
As far as the borked install command goes, i think i should be fine, libreoffice works as before.

Offline

#4 2012-12-23 13:31:31

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,193
Website

Re: Warning message while upgrading libreoffice-common

Yes, most likely mimi should be changed to not list that in the provides array.  If it does list it, it should replicate the behavior of all included tools/executables, or at the very least, it should provide all those executables even if they do nothing (eg an empty script).

I suspect many who prefer mimi to xdg-utils would not want the behavior of xdg-icon-resource to be replicated, so perhaps an empty script would be the way to go - but I'm not sure if one could then say it 'provides' that.

Last edited by Trilby (2012-12-23 13:32:50)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB