You are not logged in.

#1 2012-12-26 05:29:49

prokonsole
Member
Registered: 2012-12-15
Posts: 28

[solved] - vlc - non starter

[hugh@localhost ~]$ vlc
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0x22c8108] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Segmentation fault (core dumped)
cat /var/log/pacman.log | grep -i 12-26
[2012-12-26 11:21] Running 'pacman -Syu'
[2012-12-26 11:21] synchronizing package lists
[2012-12-26 11:21] starting full system upgrade
[2012-12-26 11:24] upgraded fribidi (0.19.4-1 -> 0.19.5-1)
[2012-12-26 11:24] upgraded libkgapi (0.4.3-2 -> 0.4.4-1)
[2012-12-26 11:24] upgraded libtasn1 (3.1-1 -> 3.2-1)
[2012-12-26 11:24] upgraded ocaml (4.00.1-1 -> 4.00.1-2)
[2012-12-26 11:24] upgraded python2 (2.7.3-3 -> 2.7.3-4)
[2012-12-26 11:24] upgraded tcl (8.5.13-1 -> 8.6.0-1)
[2012-12-26 11:24] upgraded tk (8.5.13-1 -> 8.6.0-1)

Previously working vlc isn't starting after today's upgrade.
Previous posts here and on the web refer to similar non starting vlc problems with either prelink (which is not installed, so its not that) or an upgrade of glib which sometimes needs to be rolled back.

I do not see glib in the upgrade list from this morning so perhaps it's not that either.

smplayer still works. I am new to arch so I am not assuming anything about what has gone amiss.

If you wish to contribute a helpful response please do,

Thanks

Last edited by prokonsole (2012-12-27 19:13:49)

Offline

#2 2012-12-27 12:07:46

des-b
Member
Registered: 2012-12-27
Posts: 4

Re: [solved] - vlc - non starter

Hi, same problem here. I think this have somthing to do with qt.

dmesg reports the following:

vlc[5233]: segfault at 100000006 ip 00007f790851d439 sp 00007f7906178c20 error 4 in libQtCore.so.4.8.4[7f79084a5000+2ca000]

Running svlc, nvlc, cvlc, ... does not make any problems.

Im new to Arch. My installation is just a few days old. Maybe i missed some dependency on installation?

Thanks

Offline

#3 2012-12-27 13:08:21

ez
Member
Registered: 2012-12-24
Posts: 2

Re: [solved] - vlc - non starter

Same problem here...

In another thread someone suggested a workaround which does not use QT:

vlc -I skins2

However this doesn't help opening media files from a GUI (ie. double-click a file).

Eyal.

Offline

#4 2012-12-27 13:17:02

des-b
Member
Registered: 2012-12-27
Posts: 4

Re: [solved] - vlc - non starter

A quick & dirty workaround would be to run it like you said:

vlc -I skins2

Then right click -> Interface -> Properties and there change "Look & Feel" to "Use custom skin".
Then vlc would load the skin by default. Then you should be able to double-click on files.
But this is no real solution... and i really do not like the skinned interface ...

Offline

#5 2012-12-27 13:35:37

des-b
Member
Registered: 2012-12-27
Posts: 4

Re: [solved] - vlc - non starter

Ok, now it works. I have done it like explained here

pacman -S vlc
/usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins
pacman -S vlc # just to be sure ;)

strange ...

Last edited by des-b (2012-12-27 13:36:26)

Offline

#6 2012-12-27 13:55:01

ez
Member
Registered: 2012-12-24
Posts: 2

Re: [solved] - vlc - non starter

Thanks des-b, the workaround and the fix both work!

Offline

#7 2012-12-27 19:12:53

prokonsole
Member
Registered: 2012-12-15
Posts: 28

Re: [solved] - vlc - non starter

des-b wrote:

Ok, now it works. I have done it like explained here

pacman -S vlc
/usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins
pacman -S vlc # just to be sure ;)

strange ...

Thanks for that. I 'd better sharpen my forum search technique as I sure as shootin' didn't find that post you saw - had all my keywords too: segmentation; vlc etc.

uh what does this command do?

pacman -S vlc #

Ta

Offline

#8 2012-12-28 11:59:47

des-b
Member
Registered: 2012-12-27
Posts: 4

Re: [solved] - vlc - non starter

I had also problems to find the thread. To be honest, the forum internal search function didn't help much wink
After searching on google with the "site:" option I've found it.

prokonsole wrote:

Thanks for that. I 'd better sharpen my forum search technique as I sure as shootin' didn't find that post you saw - had all my keywords too: segmentation; vlc etc.

uh what does this command do?

pacman -S vlc #

Ta

As far as I understand (I'm new to Arch) this command tells pacman to reinstall vlc without changing anything on the dependent packages. You could also completetly remove and install it again. But this would be a lot more work to do, bacause there is a dependency to "phono-vlc". And this also can have other dependencies ... and so on ...
I just was'nt sure when to do the reinstall. So I've done it before and after this "vlc-cache-gen". (just to be safe)

Maybe someone else in the forum has a better explanation xD

Offline

#9 2012-12-29 10:11:18

moneo
Member
Registered: 2012-12-29
Posts: 2

Re: [solved] - vlc - non starter

Thanks, refreshing the cache did it.

# sudo /usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins

Offline

#10 2013-02-17 00:18:53

thenextdon13
Member
Registered: 2013-01-18
Posts: 47

Re: [solved] - vlc - non starter

Worked for me as well.

Offline

Board footer

Powered by FluxBB