You are not logged in.

#1 2012-12-26 09:07:29

renq654321
Member
Registered: 2012-12-26
Posts: 2

gcc 3.3.6 install error

Hi, all!
  I want to install an older version of gcc, that is gcc-3.3.6, to compile the LEDA library.
  I did my steps following this article.
  http://www.linuxfromscratch.org/blfs/vi … /gcc3.html
  I downloaded the source code and patchs, and
 

  patch -Np1 -i ../gcc-3.3.6-no_fixincludes-1.patch &&
  patch -Np1 -i ../gcc-3.3.6-linkonce-1.patch &&
  mkdir ../gcc-build &&
  cd ../gcc-build &&
  ../gcc-3.3.6/configure --prefix=/opt/gcc-3.3.6 \
      --enable-shared --enable-languages=c,c++ --enable-threads=posix &&
  make bootstrap

  But it seems I still cannot install gcc-3.3.6 correctly and here is the errors.

make GCC_FOR_TARGET=" ./xgcc -B./ -B/opt/gcc-3.3.6/i686-pc-linux-gnu/bin/ -isystem /opt/gcc-3.3.6/i686-pc-linux-gnu/include -isystem /opt/gcc-3.3.6/i686-pc-linux-gnu/sys-include" \
  BUILD_PREFIX="" BUILD_PREFIX_1="ignore-" \
  AR_FOR_TARGET="ar" \
  AR_CREATE_FOR_TARGET="ar  rc" \
  AR_FLAGS_FOR_TARGET="" \
  CFLAGS="-g  -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long " \
  RANLIB_FOR_TARGET="ranlib" \
  RANLIB_TEST_FOR_TARGET="[ -f ranlib ] || ( [ "i686-pc-linux-gnu" = "i686-pc-linux-gnu" ] && [ -f /usr/bin/ranlib -o -f /bin/ranlib ] )" \
  NM_FOR_TARGET="` if [ -f ./nm ] ; then echo ./nm ; elif [ -f /root/Desktop/tale/gcc-build/gcc/../binutils/nm-new ] ; then echo /root/Desktop/tale/gcc-build/gcc/../binutils/nm-new ; else if [ "i686-pc-linux-gnu" = "i686-pc-linux-gnu" ] ; then echo nm; else t='s,^,i686-pc-linux-gnu-,'; echo nm | sed -e $t ; fi; fi`" AWK="gawk" \
  LIBGCC2_CFLAGS="-O2  -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -isystem ./include  -fPIC -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED " \
  INCLUDES="-I. -I. -I../../gcc-3.3.6/gcc -I../../gcc-3.3.6/gcc/. -I../../gcc-3.3.6/gcc/config -I../../gcc-3.3.6/gcc/../include" \
  CONFIG_H="tconfig.h " MACHMODE_H="machmode.h machmode.def ../../gcc-3.3.6/gcc/config/i386/i386-modes.def" \
  LIB1ASMSRC='' \
  MAKEOVERRIDES= \
  -f libgcc.mk all
make[3]: Entering directory `/root/Desktop/tale/gcc-build/gcc'
for d in libgcc; do \
  if [ -d $d ]; then true; else /bin/sh ../../gcc-3.3.6/gcc/mkinstalldirs $d; fi; \
done
if [ -f stmp-dirs ]; then true; else touch stmp-dirs; fi
./xgcc -B./ -B/opt/gcc-3.3.6/i686-pc-linux-gnu/bin/ -isystem /opt/gcc-3.3.6/i686-pc-linux-gnu/include -isystem /opt/gcc-3.3.6/i686-pc-linux-gnu/sys-include -O2  -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -isystem ./include  -fPIC -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED  -I. -I. -I../../gcc-3.3.6/gcc -I../../gcc-3.3.6/gcc/. -I../../gcc-3.3.6/gcc/config -I../../gcc-3.3.6/gcc/../include -fexceptions -c ../../gcc-3.3.6/gcc/unwind-dw2.c -o libgcc/./unwind-dw2.o
../../gcc-3.3.6/gcc/unwind-dw2.c: In function `uw_frame_state_for':
../../gcc-3.3.6/gcc/unwind-dw2.c:954: error: field `info' has incomplete type
make[3]: *** [libgcc/./unwind-dw2.o] Error 1
make[3]: Leaving directory `/root/Desktop/tale/gcc-build/gcc'
make[2]: *** [libgcc.a] Error 2
make[2]: Leaving directory `/root/Desktop/tale/gcc-build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/root/Desktop/tale/gcc-build/gcc'
make: *** [bootstrap] Error 2

  I have tried to Google for it, but nothing helps.
  Do you have any suggestions?
  Thank you for your advise.

Last edited by renq654321 (2012-12-27 01:54:42)

Offline

#2 2012-12-26 16:05:18

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

Re: gcc 3.3.6 install error

renq654321, welcome to the forums. Pease use [ code ]...[ /code ] tags (without the intervening spaces) around code sections. It will make them far more readable in a scrollable window.

For more info see here. You may always use the "BBCode" link below the edit window for help on this.


To know or not to know ...
... the questions remain forever.

Online

#3 2012-12-26 16:17:10

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,721

Re: gcc 3.3.6 install error

1. stop compiling as root
2. you need extra patches to build gcc 3.3.6 using gcc 4.7
3. It might be less work to fix the ouydated code than to try to get gcc 3.3.6 built
4. use a PKGBUILD/makepkg

Last edited by Mr.Elendig (2012-12-26 16:17:52)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#4 2012-12-27 08:15:53

renq654321
Member
Registered: 2012-12-26
Posts: 2

Re: gcc 3.3.6 install error

Mr.Elendig wrote:

1. stop compiling as root
2. you need extra patches to build gcc 3.3.6 using gcc 4.7

I have no idea about the extra patches, they only listed two patches.
Any suggestions?
Does the GNU make version matter?

Offline

#5 2012-12-27 11:45:30

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,721

Re: gcc 3.3.6 install error

Yes it does, see the porting guides that gcc has on their homepage.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

Board footer

Powered by FluxBB